Loyal is the Heart quest bugged

Discussion in 'Bug Reports' started by Orcen, Dec 18, 2022.

  1. Orcen Elder

    Category: Quest [Can Repro]
    Date/Time: Sun Dec 18 14:59:46 2022

    Character: Level 120 Magician (Main)
    Zone: Caverns of Endless Song

    Description: Loyal is the Heart quest in Caverns of Endless Song.
    Second Step, Defeat the siren that stole Dagada's sword...
    at 10%, instead of the a sword thief de-spawning and getting the sword, the mob just becomes immune to damage, then walks away, aggroing everything along her walk, sending a huge train after us. Tried a couple times now, and same thing.. Cannot get this step to update so cant complete tasks here. Mob is bugged..
    Brickhaus likes this.
  2. Orcen Elder

    as a follow up... this eve I snared the thief, killed the add in room first, at 10% the mob became immune, didn't walk away cause was snared. Tried everything to lose aggro. It wasn't attacking anymore, but held us in aggro. Left the room, used cover traks, mage coh'ed ranger, could not lose aggro and get out of combat even though it wasn't attacking.
    Tried what memory jolts i could, just could not achieve out of aggro, Thiedf wasnt in the extended target window though.
    Left the area and went all the way to quest room and still couldn't get out of combat. After a while, add in the room re-popped and showed up in extended target window, but didn't come to us as we were way too far away.
    when I saw Thief's HP go to 11% and start rising again ranger was able to achieve out of combat. Mage couldn't.
    Finally camped the mage in zone, and ranger saw the room add in the extended target window clear. Mage zoned back in and all was cleared.
    BUT, we didnt get the sword..
    The rest of task was completed just fine, we just don't have a sword and can no longer progress through Darkened Sea expansion. This one task is holding everything up.
    Maybe a GM could pop in and update task and give us a sword, (Cinadin and Start on Povar Server) so that we can move on.
  3. Gialana Augur

    It sounds like there's a bug here. The thief is supposed to depop at 10%, not just go immune to damage. But you don't actually ever get a sword during this quest. After that step updates, and it sounds like it won't for you, you swim down to the seafloor under that coral formation. There you click the sword, which spawns an octopus you must kill.
    Orcen likes this.
  4. Orcen Elder

    yes did the Shield and popped octopus, all other steps done.. he wont de-pop and update task. Really frustrating because progression wont allow me to next zones until this guy updates my task. four tries all the same.

    Can A GM repop zone please and let us know, maybe that fix the bugged mob? GM???
  5. Zenn-La New Member

    All progression stopped through Darkened Sea because this the siren thief wont de-pop and update the task.
    Can we at least try to re-pop the zone or something, maybe that would fix it? Povar server, Caverns of Endless Songs

    Orcen likes this.
  6. Zenn-La New Member

    Just do it, huh?
    Orcen likes this.
  7. Orcen Elder

    Just wanted to post and say that after last patch, the broken "sword thief" was fixed. As suspected a reboot of the zone fixed it.
    Wish a GM could pop in and do a re-pop of zone without waiting weeks for a patch huh?
    Thanks for not helping.
  8. Atlans Lorekeeper

    This has been happening since release really. To get the thief to update/depop you need to do some melee dmg. Spell, pet, DS dmg doesn't do it - must be melee dmg. I learned this the hard way in an all mage group.
    Orcen likes this.
  9. Ruckmaul New Member

    This was bugged again today. No amount of melee damage from the bard changed the outcome: sword thief just walked at 10%. Please fix!
    Orcen likes this.
  10. Orcen Elder

    Please! Can someone at EQ fix this mob. Get mob to 10% and it stops fighting, then walks away aggroing everything it walks past. It does not de-spawn and update the quest, it does not give the sword needed for the quest. After a while it will walk back, can re-engage and same thing, at 10% just walks away. IT is supposed to de-spawn and up-date quest by giving you the sword needed for the quest.
    Was doing this back in December 2022, lots of complaints about this is forums. This one bugged mob stops all progression through the expansion, cannot get to the next quests or zones thill this bugged mob is fixed.
    Please DO SOMETHING!
  11. Orcen Elder

    Still bugging.
  12. Soulbanshee Augur

    Sure, but the workaround has been posted. Use no pets, no swarm, no mercs, a player must be tanking and meleeing on top hate inside the shell, don't drag it out.
  13. Tserstrahd New Member

    I experienced this bug when trying to gain progression for explorer achieves on an 122 necro. I had to log in a lower level character 110 Bard persona that could gain EXP from mob and it FINALLY popped away. Never had issue with this before.
  14. Flanglais New Member

    Currently bugged out on The Rathe...
  15. Moak The Most High

    I made a level 100 alt and am trying to do TDS progression- The sword thief is nowhere to be found. I can target it using /tar a_sword, but cannot see it or melee it. I can also sic a pet on it but it gets to 10% and does not despawn/update/ give up teh sword. T^his is a pretty old post thread to not be fixed yet