Info Needed Losing mouse, repeatable

Discussion in 'Bug Reports' started by Koryu, Oct 29, 2019.

  1. Koryu Professional Roadkill

    This is an intermittent bug, so I can't give you a guaranteed set of steps to reproduce.

    Description: When being knocked unconscious in combat, but then rescued from death by a heal, sometimes the player will find that they are no longer able to use their mouse to interact with the UI. The game treats the mouse as if the character is still unconscious, not able to activate buttons or spells by clicking on them with the cursor/pointer.

    I am specifying that the problem is the mouse, because buttons and abilities can still be activated with keyboard shortcuts. Commands and chat can still be typed.

    The bug resolves itself after a random period of time. I am not sure if there is a specific game action that causes the bug to clear up, it is usually gone within 1-2 minutes, but that is time that the player may still be in combat with a raid boss (especially as a tank, being prone to getting knocked unconscious). I have heard people say that changing camera view helps them, but it has never worked for me.

    I feel like this isn't enough detail to narrow down this bug, so if anybody has more detail, please provide it.
    Mithra, Silvena, Moege and 31 others like this.
  2. Tyreel Augur

    Possible workaround/fix it may not work for everyone but this has only failed for me once since the custom UIs became possible.
    When you get this bug do Alt+Enter to toggle full screen/windowed mode then do any action i use /stopcast then Alt + Enter again.

    Some people say this makes them crash and i have a feeling that crash is related to Windowed or Full screen section of their UI_Name_Server.ini pointing to an old invalid or broken UI/Layout. Since many people exclusively use windowed mode or full screen mode toggling Alt+Enter alone might crash them at any time due to old outdated custom UI folders or just garbage in that specific section of the UI_Name_Server.ini file.

    Also the Alt+Enter will help if you are stuck on death screen and cannot click for revive or release.
  3. Zinth Augur

    I have several times lost the ability to "click" anything with my mouse in-game after one of the latest patches...

    I usually use right mousebutton held down to "look around" and that becomes impossible as well... all the times I have noticed it happen is after I "go down" as a tank... "purpling" and then standing up as the heal land = mouse gone... if "divine save" is involved I don't know but the times I have had it happen has mostly been in raids (once outside of raids where I have might have "divine save" on me) mouse works perfectly when tabbing out of the game and restarting the game makes it work again... the cursor can still be "moved" around but you can't interact at all with the game, which makes it quite difficult when you tank 4-5 mobs and have to keep em all placed infront of you etc. and being unable to mouseclick your disciplines because they are not on keyboard shortcuts but just on mouseclicks for me...

    and no it isn't the F12 to disable mouse etc. thing...
    Cyphren, Eyashusa, Laurana and 3 others like this.
  4. Duder Augur

    I also experienced this after the patch after going unconscious or "purpling". Exactly as you described, tried all the normal methods of re-activating or resetting things. F12, trying to use an AA ability via keyboard hotkeys. I don't have any sort of gate item hotkeyed on any page so was unable to try that. But was about to /q when the mouse control finally returned over 30s later.
    Zinth likes this.
  5. Duder Augur

    As added info: My experience was from a Shaman.
  6. Skuz I am become Wrath, the Destroyer of Worlds.

    I've experienced this once or twice but not recently, I had to minimize window & then maximise again (I play in windowed)

    I also get a bug where my keyboard command turn to nonsense, fixed same way.
  7. Zinth Augur

    any news on this? kinda an annoying bug
  8. YabaHow New Member

    I have lost my mouse ability several times over the last few weeks (never used to).
    I play a Pally and only group geared so I tend to use "the full health bar" when tanking :-(

    Interesting you mention that if you purple this problem happens. I have not correlated those two together yet, but I will start paying attention to see if that is the trigger (or try not to get purpled :) lol )

    I have gotten my buttons/mouse back once by minimizing my EQ game (I play in full screen mode) and opening a NotePad (typing in there) and then went back in to the game. One time that method worked for me, the other time I had to restart EQ.
  9. Horse Journeyman

    I have also lost the ability to click with the mouse in eq. Keyboard works. mouse does not. Tab out to windows (I play full-screen) and the mouse works fine.
  10. Kaosmos Lorekeeper

    This happens to me when "get purple clubbed" fall down bleeding but do not die then receive a heal. Has happened for years to me, usually have just /quit to fix
  11. Eyashusa Lorekeeper

    I have had this happen recently and it was suggested to click both mouse buttons at the same time. This did the trick for my but YMMV.

  12. Duder Augur

    I had this happen just now. Went unconscious and I could not click anything whatsoever with my mouse (in that window, other windows were fine). After about 30 seconds the mouse control returned as expected. About 2 minutes later I went unconscious again and once again lost mouse control. The second time it never returned and I had to relog to fix it... mid raid.
  13. Svann2 The Magnificent

    I dont normally use my mouse to click anything, but I do use my mouse to move both forward using both mouse buttons, and backward using side mouse button. Sometimes when I purple I come out of it moving backwards as if I still have the side button pressed. I can control it by moving forward but as soon as I let go of left/right mouse I start moving backward again. It stops after about 20 seconds I guess. Really rare because I dont purple very often.
  14. Duder Augur

    Does QA In Progress mean that a fix is being tested? This bug is still around and easy to replicate.
  15. Ratalthor Developer

    QA In Progress means that our team is working on finding reliable reproduction steps.

    If you are able to replicate the issue reliably, please share them in this post and the testing team will see them.
  16. Ratalthor Developer

    Does this issue still happen to anybody?
  17. Fezagorn Apprentice

    Yes, often. It's usually related to attempting to click on an ability on a hotbar and at the same time you get knocked unconscious. When you get back up (without dying), any subsequent clicks show the same ability attempting to be pressed over and over and you can't click on anything else on the UI.
    Happens with the Default UI.
    Nerple and Moege like this.
  18. Laurana Augur

    Happens often. Playing a paladin, when I purple and come back to life, can't use the mouse. Ducking fixes the problem. Frustrating trying to get that instant heal off before I die again! This may have overlap with that Ranger bug where buttons are not usable after using a sequence of discs, or whatever it is (I don't play a ranger, just recall reading that thread and thinking it sounded a lot like what I experience).
    Moege likes this.
  19. Bigstomp Augur

    Happened to me this evening.
    I was tanking Nosja in ToFS2 at the time.
    I fell down (not sure how low on hp but enough to lay down) and was then healed back up.
    At that point my keyboard still worked but my mouse could not click anything.
    Mouse itself was still working for other things like my push to talk key.

    Interestingly, when I finally died I was able to click again. Rez dialog box worked fine.

    I can provide logs of roughly the time period it happened if that would help.
    Moege likes this.
  20. Skuz I am become Wrath, the Destroyer of Worlds.

    Still happens, as recently as this week I have had this bug occur, only commonality appears to be getting "purple clubbed" and saved from death.
    Bigstomp, Fezagorn and Moege like this.