Live Update Bugs 12/19/17

Discussion in 'Test Update Notes and Bug Roundup' started by EQ Dev, Dec 19, 2017.

  1. mehtsenob Elder

    Vendors are still resetting back to the top of the list when making a purchase.

    This is extremely annoying when you are scrolling down the list buying needs, perhaps, alphabetically.
  2. klanderso Developer

    The fix is currently being tested internally.
    Shimmerleaf likes this.
  3. Jetslam Lorekeeper

    The agi/str buffs haven't been updated since level 86. They are the same on the level 101/105 unity spells. Only the focus/sta portions are new.
  4. mehtsenob Elder

    The Parcel Vendor on Overthere is also the Group Coin Vendor.

    While you can get stuff from the parcels, he refuses to send anything.

    For some reason he thinks you are trying to sell it to him for the group coins, refuses to buy it and the SEND button stays grayed out.
  5. klanderso Developer


    This is another one that's currently fixed internally and being tested to ensure it's working correctly.
    Shimmerleaf likes this.
  6. Wulfhere New Member

    Salus Faycite Shard: Ardent Healing still doesn't work at all. You patched the recourse spell group but not the item focus to match.

    Compare it to Salus Faycite Shard: Merciful Healing
  7. Ngreth Thergn Developer

    That item has the wrong wording on it. All of the armor charms in the expansion work the same way. It should say "This charm improves as you wear more class-specific armor from Ring of Scale." Only Phlogiston Charm of Security had the correct message attached. The rest had the old message.
    I fixed the wording internally but it needs a full patch to go live.
    This is fixed internally but it needs a full patch to go live.
    Shimmerleaf likes this.
  8. Smokezz Augur

    - Glyph of Arcane Secrets II doesn't work on the new spells
    - Global drops don't drop in RoS
    - It seems the EoK rares that were supposed to drop in RoS... don't drop in RoS. It's been over a week, and not a single one has been seen in guild yet. With the number of mobs dying, there should have been a few by now. Similar issue to the globals above?
  9. Metanis Augur

    Cleric spell "Silent Directive" level 109 is our PBAE stun. Only stuns up to level 105 mobs? Shouldn't it be 110? Otherwise what's the point?
  10. Metanis Augur

    Cleric spell Hammer of Repudiation level 107?

    Had to be 107 to buy and scribe the spell. Once conjured the resulting weapon is only 103 Req Level.

    Stats do not appear to be properly scaled to RoS expansion compared to Level 88 conjured hammer!

    This thing should be much stronger than it is. For example old hammer is 80 max skill mod to 1hb, new hammer is exactly the same. Both hammers have exactly the same Focus effect, Sympathetic Healing Burst XIV. Both hammers have exactly the same Bane Dmg Undead of 30. The level 88 hammer has a base dmg proc of 5549 (at level 88!!) while the new hammer is just 6104 although it does have a further modifier for undead and elementals. Finally, the level 88 hammer was BETTER than raid gear for that era, while the new hammer is much WORSE than even EOK raid gear. Would it be too much to ask for that clerics get something that might actually be fun to play with? That might actually be an upgrade for some of us?
  11. Sirene_Fippy Augur

    I have seen an EoK rare drop in RoS.
  12. Metrav Journeyman

    Wrapped Conflagrant Gem of Security. -> Had 2 of them in a stack, and clicked convert. Lost both Wrapped Conflagrant Gem's and only got 1 Aug.
  13. mehtsenob Elder

    They are lore -- you can only possess one.

  14. Naonak Journeyman

    Having the same issues with merc AAs. Not earning xp. When I do after a reset here and there, it bugs out again and resets the current level back to zero %. Now leaving my main 5 AAs short of my alt accounts/toons.
  15. Tannin Steelblade Journeyman

    Tradeskill combine...

    Had the Tradeskill potion running drought of the craftsman while combining earring quest final. Used the extra time to make some new fancy tradeskill stuff.. Tuns out only issue i had was during the combines for Bard armor (only one i tried) If you fail the combine you WILL loose some of the Conflagrant sheets in the fail. i failed 3 times and for some reason each time i only lost 1 sheet. Was trying the bard BP. Failed x3 each time only thing that dissapeard was 1 sheet other 2 popped up on cursor. Not sure if this will be the same with the rest of the tradeskill items where you can fail with the dropped component with the Tradeskill pot running. Was this an oversight or feature? lol. Just letting ya know etc .. thanks

    And also.. just found this out.. I had 4 wrapped gems of adroitness stacked up in my inventory i right clicked and all 4 poofed into 1 aug :( Might wanna check this one out ..
  16. Ngreth Thergn Developer

    Define "Global Drops" there are many of them, and I know some are happening since some of the tradeskills are happening.
    If you mean Cash Loot drops. Yes. They do not drop. I left them off intentionally but changed my mind post-launch. They will start in the Jan patch.
    Ultra Rare is Ultra Rare. The table data looks good. Here's the data in case you doubt me:

    GLOBAL_LOOT_ZONE
    GLOBAL_LOOT_IDZONE_IDZONE_NAME
    17302 788 drogab
    17302 789 charasisb
    17302 790 scorchedwoods
    17302 791 frontiermtnsb
    17302 792 gorowyn
    17302 793 korshaext
    17302 794 lceanium
    17302 799 korshaint
    17302 800 chardoktwo
    17302 813 charasistwo
    17302 814 skyfiretwo
    17302 815 overtheretwo
    17302 816 veeshantwo

    Known issue. It's why the type 5's don't stack, I somehow missed the 4/7/8 augs when I removed stacking. This issue is fixed internally(a Code issue) and with the next live patch, they will stack and only consume one from the stack when converted.
    It's looking more like there is an issue with the spell effect that drought of the craftsman is using. The conditions of its failure to be 100% salvage are too varied to be what I guessed it was. I thought it might be Fishing not included, but this is Smithing. I thought it might be alt-fail, this combine does not have an alt fail... so... I'll have to punt this to the code team. {Snip - See below}.
    As for your second issue with the convert eating stacks. see above in this post :/
    Ishtass likes this.
  17. Ngreth Thergn Developer

    Hrm. I think I figured out that the Drought is working as designed... perhaps not as interpreted.

    In order to not duplicate items, salvage does not return items that you get back on failure. For example, the smithy hammer in the Maestro's Conflagrant Breastplate is returned on failure.

    What's happening here, and many of the Ring of Scale combines, is that I decided to NOT make them all or nothing. If you fail at the Breastplate, for example, you get two Conflagrant Metal Sheet returned. I.E. you only ruin one sheet in your failure. (and lose the water, emblem, loam, and coal.)

    Believe it or not, for COMPONENTS, the tradeskill system has no concept of number of components. Instead, there are 10 slots for components, and it simply looks for all slots being filled with the correct components. NOT that three Conflagrant Metal Sheet are required. It more that it sees Conflagrant Metal Sheet | Conflagrant Metal Sheet | Conflagrant Metal Sheet is required. (part of the recipe, the whole thing is: Smithy Hammer | Emblem of the Maestro | Phlogiston Coal | Phlogiston Loam | Water Flask | Breastplate Template Mold | Conflagrant Metal Sheet | Conflagrant Metal Sheet | Conflagrant Metal Sheet.)

    I *EXPECT* what is happening here (This is an educated guess by me. I am not on the code team so have not looked at the code at this writing) when it's stepping through the components to roll salvage it gets to Conflagrant Metal Sheet and sees that in the failure return is Conflagrant Metal Sheet and to not create duplicate items, it skips. Gets to the next one, skips, next one, skips, and reaches the end of the recipe... It has absolutely NO concept that there are three sheets, so it is expected by some to roll salvage for one.

    So in short... it's working as designed, not as interpreted.
  18. Malbro Augur

    Merc AA exp is still broken, mine just went from positive 90 to negative 39% just now.
  19. Smokezz Augur


    I trust when you say it's there. :) And yes, it was things like diamonds, the usual silks, ores, etc.

    I assume the lack of answer on the Glyph means that was an intentional thing to not have it work on the new spells. heh. If not a bug, not a happy change, but survivable.
  20. Ngreth Thergn Developer

    I didn't answer because it's not something I worked on, so I do not know the answer. I have no information on intended or not.

Share This Page