Live Update Bugs 02/21/18

Discussion in 'Test Update Notes and Bug Roundup' started by EQ Dev, Feb 21, 2018.

  1. Vandir Lorekeeper

    I don't think this is new, and is a bit of a question...

    Are individual tradeskill masteries supposed to be marked SoL or OoW? Currently Jewelcraft Mastery and Alchemy Mastery are purchasable in SoL, while the rest are locked, on Agnarr.

    I believe this was the same on Phinny -- I found a couple old bug reports in the DGCtracker that seem to reference this -- but they went unanswered. I presume this will become a question on Coirnav, as well.
  2. Krrill New Member

  3. Zaviere Augur

    To add to the above comment about the Quest Overlay window... not only does it reappear on its own as described, but the General Options settings to Auto Add Task Overlay and Show Only Open Steps reset to *ON* every time I log out and back in. This is kind of annoying, as I have no desire to make use of the overlay at all, but find myself having to deselect these options at the start of every play session to prevent the window from displaying stuff whenever I obtain a quest. A fix that allows the status of those two options to be saved when logging out would be fantastic.
    Jiggs likes this.
  4. CatsPaws Augur

    Not sure if this works on custom ui but discovered that if you go to the EQ Button - Quests - Task Overlay that this setting will supersede any setting put in on General Options. There is only "on" or "off" if you choose Task Overlay thru the button. So if you choose off it will not matter what you have in the general options. I have Auto add and show only open steps selected but no overlay shows until I turn it on under EQ Button
    Zaviere likes this.
  5. Zaviere Augur

    Okay, I see what I was doing wrong all along, on all fronts, LOL.

    Feel free to disregard my previous post /cough
  6. Evil.Iguana Elder

    No dev input on this? Hate to bump my own reply but seems like all the other bugs in thread have been acknowledged. I know I'm not the only one having the issue.
    Jiggs likes this.
  7. Ismel Augur

    Do not get the song window buff from Skull of null
    Tried relogging, zoning, trading skull to a npc and swapping it from bag to equipped and back, can right click it for the dispel just fine.

    Happens to both my chars Ismel enchanter AB and Zindll Magician AB
  8. Aanuvane Augur

    Is there any plan to fix the naming duplication on the higher level poison tradeskill drops? It's a real pain to figure out if you have Tainted Caladium item number 152656 or Tainted Caladium item number 76916. Can we please get this naming problem fixed?

    Tainted Caladium 152656
    Tainted Delphinium 152659
    Tainted Laburnum 152657
    Tainted Larkspur 152655
    Tainted Muscimol 152653
    Tainted Oleander 152654
    Tainted Privit 152658

    Need a different word besides "Tainted" to describe them and need to have their item details updated to Required level of 105?
    AB_H'Sishi and eepok like this.
  9. Ngreth Thergn Developer

    I have a GUESS at what is happening. But I will need to consult with code. Thanks for the extra detail, that's a great help.
    For this, I don't want to talk about my guess yet.
    I have a guess here are well. Before the patch, the Skull of Null was NOT an evolving item. Now it is an evolving item. Since *some* of the pertinent data to evolving items is "instance" data (data specific to the specific item that your character has and not the Skull of Null item in a general item sense.) So the game may not be "able" to attach that instance data to a Skull of Null item that existed before the patch that changed it to an evolving item. (It is an evolving item with no steps that takes no exp... I abuse the evolving "intelligent" (talking) item code to make it run the scripts needed to make the shielding buff work.)

    At this point, I have no idea what the solution may be, if there will be one, or how soon. If, as I am told, these are "so ridiculously easy to acquire that they should not be called chase items"... then... your fastest bet may be to do the quest again. (Destroy the skull you have before you make the hand-in to the gnome!) (I am saying fasted method... not necessarily best... etc... Totally your choice.)
    Ssdar likes this.
  10. Imortus New Member

    The bugs that I am experiencing are that ever since the patch, I am getting an extremely low frame rate in the game now. I am also experiencing the sound issue where no matter where the volume is at, in game or windows, there is a lot of reverb and everything is super loud. I have tried going in and out of windowed mode to fix the graphical lag, to no avail. I have tried with and without a custom UI (which was updated) and still getting extremely low FPS. I also tried validating my files and no errors were found. Any help on this issue would be greatly appreciated, as I cannot play like this. Thanks!

    Edit: the only thing I can see in my logs that show any sort of errors are the following:
    [Thu Feb 22 11:13:58 2018]00222:D3DXCreateTextureFromFileEx()failed to create texture flare.ddsforparticle system.

    [Thu Feb 22 11:13:58 2018]00223:D3DXCreateTextureFromFileEx()failed to create texture sparkle01.ddsforparticle system.

    [Thu Feb 22 11:14:00 2018]00224:D3DXCreateTextureFromFileEx()failed to create texture pt_add_smoke.ddsforparticle system.

    [Thu Feb 22 11:14:01 2018]00225:D3DXCreateTextureFromFileEx()failed to create texture fire01.ddsforparticle system.

    [Thu Feb 22 11:20:17 2018]00226:D3DXCreateTextureFromFileEx()failed to create texture fire_missle.ddsforparticle system.

    [Thu Feb 22 11:20:17 2018]00227:D3DXCreateTextureFromFileEx()failed to create texture flare.ddsforparticle system.

    [Thu Feb 22 11:20:19 2018]00228:D3DXCreateTextureFromFileEx()failed to create texture soft_oval01.ddsforparticle system.

    [Thu Feb 22 11:20:19 2018]00229:D3DXCreateTextureFromFileEx()failed to create texture electricj.ddsforparticle system.

    [Thu Feb 22 11:20:19 2018]00230:D3DXCreateTextureFromFileEx()failed to create texture soft_oval01.ddsforparticle system.
  11. fransisco Augur

    wow, your a beast Prathun. Working super late!
    eepok likes this.
  12. svann Augur

    Tried switching to default ui?
  13. Lily Augur

    My advanced loot window only shows ND, GD, NO. Missing are AN, AG, NV. Every time loot drops, I have to click ND, then when it goes to my personal loot, I have to verify that I want to loot it (referring to tradeable items, not just no trade). I expanded the window, but I still don't see them. I checked my loot filters, and I can see the items are markd always need. This is not happening on other toons, and it started suddenly last night after I had been on for several hours.

    Sorry if this is a repost, but I can't seem to find the post I made earlier today.
  14. Daedly Augur

    Hope this bug gets acknowledge and fixed....
  15. Ngreth Thergn Developer

    I was "on a break" during The Broken Mirror, so I can';t tell you the intentions... but...
    the scaling seems to be working, but for some reason, those rares are level + 9. With the changes, this gets capped at level 105+9 so they are level 114 if you are level 105+ (they were level 119! when players were at 110! but now stay at level 114)
    I'll ask Absor if the intent was level +4 (level 105 + 4 = 109... which is the current data)





    *if* this is a bug, it has been a bug since Broken Mirror came out.
    Daedly, adetia and mmats like this.
  16. Ngreth Thergn Developer

    I'me reasonably certain the masteries came out at different times. It's possible I'm mistaken, but I seem to remember it being uneven.
  17. Scila Augur

    TS containers (brewing so far) in GH once used - go to experiment with another recipe - unable to pick up a single item. Have closed the container and attempted to pick up a single item no luck, the item moves to another spot in the bag, or switches to another stack, but will not go to cursor or a single open slot as it did before or into the experiment container. When I relog, everything works as it should. Can repeat this every time on 2 different accounts.
  18. Uuvin Augur

    referring back to trade skill tools poofing on failure - I have hit upon the same thing. My etching tools making the augments has been eaten on both fails. It is SUPER annoying to have to run to Thurgadin on every combine attempt. This needs to be fixed PDQ.
  19. Nuggziee New Member

    I'm with ypu on this. In addition to the reverb tingy sound it also seems like some audio lag that pops at times when a lot is going on. Super annoyong
    Evil.Iguana likes this.
  20. Darchon_Xegony Augur

    On Al'Kabor the Jewelcrafting Mastery AA was filtered under Class (Luclin) for Enchanters only and the Alchemy Mastery AA was filtered under Class (Luclin) for Shamans only.

    Omens of War was the expansion that finally introduced all the other Mastery AAs and finally allowed all classes to purchase Jewelcrafting Mastery.

    So the real bug here is that all classes have access to Jewelcrafting Mastery in Luclin. It should really just be accessible to Enchanters! But really, those AAs unlock in the correct eras. They did on Phinigel and will have no problem on Coirnav. Agnarr should never expect any Mastery AAs.
    eepok and Ngreth Thergn like this.

Share This Page