linux (ubuntu) success install

Discussion in 'Player Support' started by koook, Sep 15, 2022.

  1. koook Elder

    ubuntu 22.04, tried steam version but same error as what im trying to do today, again

    spoiler since its linux


    [spoiler]


    wine winecfg winetricks with some mods installed (apt repo),
    with winetricks i installed corefonts, and a few random other fonts (below),
    installed the ?? directx and latest of 9 10 and 11 (6 check-boxes installed via graphical interface)

    seems the launcher only AFTER install process and directx installation (skip/cancel) has problems, loops an error.. some 'cef child process' with a bunch of errors,

    Though launching the launcher is working (wine launchpad), login is okay with errors in the background terminal I'm using the launch from.

    Note my computer doesn't go back to Windows anymore (it literally turned everything pink even the led on the computer) ...

    So im going to attempt and figure this out heuristically...

    Edit before Create Thread:

    I was expecting the same outcome as the last 5-10 times I tried to install standalone or via steam, though with a simple setup since the last time i erased everything and reinstalled ubuntu 22 it's working.

    Since its a bigger distro, here's what worked (maybe it'll help someone)

    apt list wine installed>
    wine
    wine32
    wine64
    winetricks

    $ winetricks > select default prefix, ok, >
    Install a Windows DLL or compenent >
    current profile blah /home/username/.wine
    d3dcompiler_47
    d3dx10
    d3dx11_43
    d3dx9
    d3dx9_43

    Install a font>
    andale
    arial
    comicsans
    corefonts
    courier
    georgia
    impact
    times
    trebuchet
    unifont
    verdana
    webdings
    ( i think most came from corefonts )

    download from site, $ wine eqsetupfile.exe
    ok install, canceled direct-x,

    navigate to the drivec dir, eq directory $wine launchpad

    logged in and working, graphics look really nice. looks 100%

    I thought I'd have questions due to the fact last builds I tried play on linux as an installer and proton with steam which goes hay-wire

    [/spoiler]
  2. koook Elder

    sorry, but there is one problem if anyone is able to help out,
    my character is stuck where they can only turn less than 90 degrees before needing to let go of the left mouse hold-down, both left and right, is this a new thing? there's no way to turn more at a time. Same with right click hold-down, where viewing the whole character in third person is no possible now
    Kind thanks
  3. Shillingworth Augur


    Had this same problem and don't remember exactly what I did to solve it. Some config stuff to maybe help ya figure out what did it.
    * winecfg -> Applications -> Windows Version: Windows 10
    * winecfg -> Graphics -> Automatically capture the mouse in full-screen windows: checked
    * winecfg -> Graphics -> Emulate a virtual desktop: unchecked

    Need to log in with the Xorg/X11 version of your desktop engine, Wayland causes problems for EQ (and many other programs). The only other thing I can think of is that I run my games through GE Proton 7.20 using Lutris as my game library (https://github.com/gloriouseggroll/wine-ge-custom).
  4. phattoni Augur

    these are the instructions i use anytime i have to install on linux.

    1. install steam
    2. enable windows games in steam
    3. install everquest
    4. install protontricks
    5. protontricks 205710 d3dx9 / protontricks 205710 corefronts / protontricks 205710 d3dx9_43
    6. add --disable-gpu to launcher options to get patcher to work.

    these are the steps required to get eq working fully on linux.

    edit the eqclient.ini to your liking.

    if protontricks doesnt recognize everquest yet, simply run the everquest client through steam, it wont work, but it will generate the files needed to make protontricks work.

    this should work with default proton installed. i do GE proton from time to time as well, it seems to handle most of my games better.



    as for the mouse going as far as left or right side of screen then stopping, i havent found a fix for this, but it happens rarely for me, this only seems to happen when i mess around with wine too much installing things that dont need to be installed.