Launchpad.exe won't run...

Discussion in 'Player Support' started by Nuggz423, Sep 13, 2017.

  1. Nuggz423 New Member

    Its been a few months since I've loaded up my EQ accounts to have a look and I tried to log in and poke around today but no matter what I do I cannot get the launcher to actually load... I run the program and the loading symbol appears on my mouse cursor for a couple moments and then everything stops.... I've tried running it in admin mode and the same thing happens.... This is the same windows install I had the last time I logged in so I'm not sure what could be causing this. Any useful suggestions would be appreciated.
  2. Bigfan Augur

    Gonna use my psychic senses to say, you're on XP or Vista?

    Those are end of life operating systems, and launchpad will not work.

    You need the updated files and run eqgame.exe patchme.

    Or upgrade os.
  3. Nuggz423 New Member

    Negative... running windows 7 and I logged into my accounts as resent as a few months ago... not sure why now suddenly it won't work...

Share This Page