launcher not working?

Discussion in 'Player Support' started by Damezza, Jun 28, 2017.

  1. Damezza Augur

    anyone else not able to get launcher working?
  2. MelediWeaver Journeyman

    Not working for me either on a Win 7 system... patchme workaround is not working either.
  3. Velisaris_MS Augur

    I tried to start it like 5 min ago and was just about to ask the same thing. I click to start the launchpad, there's network activiity as if it's maybe updating something, but then it stops and never launches.
  4. Stewgottz Augur

    Confirmed, not working. Attempted 30mins ago and just now.
  5. drewz21 New Member

    For the past 30 minutes I have tried launching EQ but nothing happens.
  6. Brudal Augur

    1st click did nothing but seems to be working now
  7. Damezza Augur

    same thing here
  8. Damezza Augur

    damn. still not working for me
  9. CatsPaws I don't like titles

    No problem here. But in the last few weeks it has been a problem off and on. I found if I restart my computer or double click on the EQ link on desktop or right click it then it seems to smack it back into place. I think with all the internet issues right now that the server stability is not the best.
  10. Flamebird New Member

    Cant log in, click the icon nada so guess its out of whack for now
  11. Damezza Augur

    ok yeah. same here. click the icon. nothing happens.
  12. Pelamar Lorekeeper

    Also having issues with my Launcher as of today when I click on LaunchPad.exe I get the Daybreak loading symbol and logo but no progression past that.
  13. Speedo New Member

    Its working fine for me, even seems faster than normal. But some people in my guild still cant get in.
  14. Damezza Augur

    anyone in your guild use crossover?
  15. Rikkish New Member


    Thats what i'm getting as well. My main computer and my wives computer is fine we got on ok 3ed computer for my shaman won't load
  16. Speedo New Member

    Not that I know of, I don't think so.
  17. ianlaplace New Member

    I use crossover and launcher keeps crashing - worked last night, stopped working this afternoon
  18. Frankrizzo New Member

    Unable to launch EQ or EQ2
  19. ianlaplace New Member

  20. Damezza Augur

    same situation. worked last night and even this morning. not this afternoon though

Share This Page