launcher bug - missing EQUI_PointMerchantWnd.xml

Discussion in 'General Beta Discussion' started by svann, Nov 2, 2017.

  1. svann Augur

    This morning when I try to server select I get the error:
    Error in your GUI XML files. Check UIErrors.txt
    When I open that file I find:
    UIErrorLog created at Thu Nov 02 08:06:51 2017
    [Thu Nov 02 08:06:51 2017] Warning: file EQUI_PointMerchantWnd.xml not found in directory UIFiles\Default\. Attempting to use file from Default skin.
    [Thu Nov 02 08:06:51 2017] Couldn't open or read UIFiles\Default\EQUI_PointMerchantWnd.xml
    [Thu Nov 02 08:06:51 2017] Error reading XML.
    [Thu Nov 02 08:06:51 2017] Error reading XML.

    Looking in my default ui directory I find it is gone, but it IS found in my custom ui directory. Running validate game assets does NOT add the file. So I copy it from customui to default ui and relaunch. Get same error and the file is gone again. Apparently the launcher is deleting the file from uifiles/default.
    --------------------------------------------------------------
    edit: found workaround.
    First tried the no patch workaround. Got a new error. Now instead of failing to find EQUI_PointMerchantWnd.xml it fails to find EQUI_NewPointMerchantWnd.xml. Isnt that special? Ok so copied that file from custom directory to default and now I am able to login.
  2. Redtuu New Member

    Getting same error, Not running a custom UI. nor do i have a custom UI folder to steal out of.
  3. Crandelston Journeyman

    Well validate dont fix and its a custom ui? I would think that you may need to get in contact with ui creator for orginal?
  4. Astinox New Member

    Getting the same error as well, and i'm not using a custom UI. Friend of mine patched and got the error too.
  5. svann Augur

    No, its not finding the file in the default ui directory. But found a fix: see edited OP.
  6. svann Augur

    No patch workaround:
    Go to your eqbeta directory. Right click eqgame.exe and choose send to desktop (create shortcut). Right click the file on the desktop and choose properties. In the target window at the very end type
    patchme /login:yourloginname
    Then rename the shortcut to something like beta no patch. This is bad because you wont get new patches tho so be sure to stop using it after they fix this.
  7. Redtuu New Member

    Had to steal the file from my live folder and copy it over then use the patchme method.
  8. Rineryen Journeyman

    Same error - tried coping the file from my normal everquest directory without luck. After running launcher the file was gone again.
  9. elumxe New Member

    The "point merchant window" (window that adventure merchants use(d) was consolidated into the regular merchant window, therefore no longer needed and thus removed.

    Even though the window was removed from the code, someone forgot to also take it out of EQUI.xml. (or tell the patcher to patch that file)

    Temporary Fix:

    Open your \uifiles\default\EQUI.xml in notepad, delete these two lines
    Code:
    <Include>EQUI_PointMerchantWnd.xml</Include>
    and
    Code:
    <Include>EQUI_NewPointMerchantWnd.xml</Include>
    save it, and run eqgame from the eqgame.exe patchme shortcut.

    I think we can expect a permanent fix next patch.
    Hiladdar and svann like this.
  10. Holyfires Elder

    Patcher repatches to lines when it can't find back to default settings which in beta is NOT FOUND.
  11. elumxe New Member

  12. Holyfires Elder

    that doesn't work when you patch it and login it replaces what you did with the old UI_file check UI files for UIERROR files and read it . Repatches even when saved from the Beta server itselfs so work around will not patch . you might be able to with Linux or custom UI programs the rest of us can't.
  13. arbre Journeyman

    Same error, default ui.

    I'll wait for a fix. I find that work-arounds just encourage procrastination. It's Beta, they can patch when they need to.
  14. Vanrau Augur

    lol they are trying hard to keep us from logging in with the invalid session and the UI errors.

    I copied both files from live into the default ui directory and ran eqgame.exe patchme. After a couple invalid session errors I was able to get in.
  15. Maxxbuff1 Elder

    Hopefully they care enough to read this and repair it soon.
  16. klanderso Developer

    My bad guys, sorry. I've got it fixed and it should be available via launchpad within the next half hour or so.
    Maxxbuff1, elumxe and arbre like this.
  17. Brehm New Member

    I was able to fix this by allowing the patcher to run and then copying over the EQUI_NewpointMerchantWND.xml and the EQUI_PointmerchantWND.xml files over after the patcher finished.
  18. svann Augur

    Cmon guys, this is part of the charm of beta.

Share This Page