Keyboard Issues. Multiple keys not working inside of EQ.

Discussion in 'General Tech Support Issues (Anything not covered)' started by ARCHIVED-JustinWK, Nov 22, 2008.

  1. ARCHIVED-JustinWK Guest

    I've been having problems ever since I've switched to a Vista machine. I have spoken countless times to Tech Support, and absolutely nothing has helped.
    Basically, the majority of my punctuation keys are working just fine outside of EQ, but not in EQ. I have tried deleting every .ini file, eqclient, even reinstalling EQ. I have tried 4 different keyboards, making sure my keyboard is set to English - US, etc... Nothing will work. Window/Fullscreen, switching EQ to Windows XP Compatible, installing Service Pack 1 for Vista, updating Keyboard drivers... The list goes on.

    I asked in General the other night if anyone else is having similar issues, and over a dozen people responded that they were. Tildes, apostrophes, quotations, etc... just don't work.

    Does anyone have a fix for this?
    I would sincerely appreciate any input!
  2. ARCHIVED-Khend Guest

    You don't by chance have an ATI video card do you?
    Somewhere way back when, I remember the ATI drivers causing that problem.
  3. ARCHIVED-CazRa Guest

    JustinWK wrote:
    Am guessing you have Vista Home Premium or higher? If so it's the eHome keyboard that is doing it. I have same problem but I can't turn off eHome keyboard since my comp is also my TV and turning it off also disables my remote.
  4. ARCHIVED-JustinWK Guest

    No, have a GeForce 9500GT.

    Cazra, do you mind elaborating? I'm a little new to Vista, and not too familiar with eHome.

    Thank you so much for your help.
  5. ARCHIVED-CazRa Guest

    Vist Home Premium and high come with Windows Media Center, and Media Center installs a device driver called Microsoft eHome Infrared Transceiver, it is used to let Media Center remotes and keyboards control the TV and media functions of Vista. Seems in some programs (like EQ) the eHome transceiver blocks certain keys. Only thing I can find to fix it is disable the eHome Transceiver and restart comp.
    Only problem with that is I can't disable it now, not sure it it's cause I have Vista x64 or it was a patch, but eHome reinstalls it self every reboot for me now :/
    http://forums.station.sony.com/eq/p...topic_id=128708 That is a thread in Tech forum about same problem.
  6. ARCHIVED-Kalevalatar Guest

    I have this same problem, it started just suddenly few weeks ago. And yes I have Vista Home Premium. Funny thing is though that my husband who also has Vista Home Premium on our second comp, his keyboard works just fine.
    It's starting to be very annoying :( My friend who has same problem wasn't able to start a quest because npc needed a key word which had ' in it.
  7. ARCHIVED-Sassinaak Guest

    Same problem here - only I have XP pro, SP3. GeForce 8800GT vid card.
  8. ARCHIVED-TigerBloom Guest

    My computer's "stats":
    Windows Vista Home Premium
    No listing in Device Manager for eHome HID devices, unless I am reading them incorrectly:
    Human Interface Devices
    HID-compliant consumer control device
    HID-compliant device
    USB Human Interface Device
    USB Human Interface Device
    Keyboards
    Enhanced Multimedia PS/2 Keyboard (the original one)
    HID Keyboard Device (the one I tried to switch out to)
    Of this thread and the following board threads on the subject of multiple keys not working inside of EQ, I am finding no response that works for my situation. Is there a response I have not been able to dig up through searching? If not, who do I approach other than posting on this board?
    http://forums.station.sony.com/eq/p...126254&#1785956
    http://forums.station.sony.com/eq/p...124047&#1751732
    http://forums.station.sony.com/eq/p...111745&#1568747
    http://forums.station.sony.com/eq/p...8&topic_id12746
    http://forums.station.sony.com/eq/p...128708&#1833010
    Thank you.
  9. ARCHIVED-TigerBloom Guest

    Well, trying to post the links for the other "resolutions" didn't work for me either.
    In the General Tech Support Issues (Anything not covered) the resolutions I've checked are:
    Subject: Cannot type certain things in game (circa early 2008)
    Subject: Problems typing certain keyboard symbols in EQ (circa late 2007)
    Subject: ~ and = key dont work in eq (circa mid-2007)
    Subject: My ' key for say does't work in chat (circa early 2008)
    In the Performance Support (Video,Sound, Crashing Issues) forum
    Subject: any real fix for certain keys on keyboard ot working while in everquest? (circa early 2008)
    Apologies for the double post, I obviously am challenged in trying to make links.
    Thanks again.
  10. ARCHIVED-TigerBloom Guest

    Searching the web brought a number of possibilities.
    This is what worked for my specific instance -- I can re-enable it when I am done playing the game -- not as convenient as I would have hoped, but usable:
    How to disable HID-compliant Consumer Control Device In Vista
    1. Go to Start menu.
    2. Select Control Panel.
    3. Select system and maintenance.
    4. Select device manager.
    5. Double click on Human Interfaces.
    6. Double click on HID Compliant Consumer Device.
    7. Click on Driver Tab
    8. Click on disable device.
    9. Restart computer
    To renable, follow the same path only in step 8 Click on Enable.
    Thanks again, for those who were looking for answers to my particular issue.
  11. ARCHIVED-Giddemore Guest

    Anyone have a work around for this yet besides disabling hardware? I'm feeling like it has something to do with the keyboard.txt file but I'm grasping.
  12. ARCHIVED-Kalevalatar Guest

    Still looking for solution :( Anyone?
  13. ARCHIVED-Sassinaak Guest

    I solved it for me....I got a new keyboard/mouse. I got a Logitec LX710 mouse and keyboard combo. Never had a problem since. I think it has to do with the drivers for certain keyboards. Try a different one and see if that helps.
  14. ARCHIVED-Kalevalatar Guest

    Updated the drivers for keyboard, no help.
    So far I have managed, but I am waiting for the day when I need to talk to NPC for a quest and I cannot type the trigger word correctly because of this, hehe
  15. ARCHIVED-augmentation Guest

    Yes, i've had the same problems on my HP laptop with Vista 64 home premium. Nothing above has worked for me as yet.
  16. ARCHIVED-Keltok Guest

    Happening here also, any fix for this?

    Using Win7
  17. ARCHIVED-NovHak Guest

    Hi all,
    I don't play Everquest, but I know how frustrating this problem can be, having had the same myself with other games. The problem arises for people who have media center versions of Windows XP or some versions of Vista (I suppose above the basic version, but I'm not sure), plus an infrared receiver, be it virtual or real.
    So here's are solutions : If you can disable the infrared device and reboot your computer, maybe it's the best for you. That doesn't work for me since I don't have a real infrared receiver. It's possible to remove the driver and make sure it's not automatically installed at next reboot, but it can be problematic for some people too. I personnally don't like this one either. My solution is : start the device manager, go to the keyboard section and remove all keyboards with eHome in their names (removing one is probably enough, but since I'm a bit lazy I didn't test yet... it probably is the « Remote control keys » keyboard but I'm not sure). Don't worry this operation is not destructive, since the keyboards will come back at next system boot/wakeup. But that means you will have to do that again after each system boot or wakeup... Once you've done that you certainly will be able to play EQ without that keyboard problem any more (until the system restarts or wakes up I mean).
    Hope this helps,
    NovHak
  18. ARCHIVED-Drakah Guest

    I just realized I had this problem after tonight playing in Underfoot.
    Last week or so, I installed a WinTV HVR 2250 in my desktop, that came with a remote for Media Center.
    Interestingly enough, it installed Microsoft eHome Infrared Tranceiver, as a Human Interface Device, which also installed 3 keyboards (Microsoft eHome MCIR 109 Keyboard, Microsoft eHome MCIR Keyboard, and Microsoft eHome Remote Control Keyboard keys), all found under Device Manager.
    Little did I know that it was the culprit all along.
    I use a USB Keyboard/Mouse combo using a receiver, since I use them wirelessly. The set I have is Microsoft Wireless Desktop Elite (Microsoft Wireless Desktop Elite Keyboard with Wireless Intellimouse Explorer 2.0).
    I do use the remote control that my TV Tuner card came with so I can be lazy and use it with the IR receiver the tuner came with, but I did not want to loose that functionality.
    So, since I do not own any keyboard that has anything to do with Media Center, all I did was this (and was surprisingly easy):
    1) Open Device Manager
    2) Click on "Keyboards" to open the tree.
    3) Right-Click on "Microsoft eHome MCIR 109 Keyboard" and choose "Uninstall", then click "Ok".
    4) Right-Click on "Microsoft eHome MCIR Keyboard" and choose "Uninstall", then click "Ok".
    5) Right-Click on "Microsoft eHome Remote Control Keyboard keys" and choose "Uninstall", then click "Ok".
    6) Click on "Human Interface Devices" to open the tree.
    7) Right-Click on "Microsoft eHome Infrared Transceiver" and choose "Disable", then click "Ok".
    You do not have to reboot.
    Now if you ever DO get a keyboard that uses Media Center, you can then go back and Enable that device, which will reinstall those keyboards again after rebooting.
    Hope this helps! :)
  19. ARCHIVED-Thulack Guest

    drak hit it on the head you have to disable the driver not uninstall it or else it will just reinstall everytime. If you use your remotes or whatever your just crap outta luck
  20. ARCHIVED-Drakah Guest

    With what I posted, I still use my remote control just fine and everything is happy. I just dont own any remote keyboards for media center.... just my wireless normal keyboard/mouse.

Share This Page