Fixed Internally Heroic Character Claims Bugged - Zero AAs Granted

Discussion in 'Resolved' started by Cragzop, Jan 11, 2020.

  1. Cragzop Augur

    See:
    https://forums.daybreakgames.com/eq/index.php?threads/heroic-character-no-aas.261976/
    for others reporting the problem.

    Have a silver account with a Heroic Character grant available (from the 2nd free give away...so just like if it was purchased). Have used the Heroic Character grant on the account from time to time to check out a class at level 85. Character would come with all the aas and the special hotkey setup that you could pick would work fine.

    After seeing the above thread, created a new toon (Drakkin Wizard). Logged him into the world in CR on Xegony. Opened the inventory screen and hit Upgrade Character button. The 3 reward windows popped for gear and I could choose the special layout for the class. But the buttons just appeared as not usable. And there were no aas granted for the toon at all (so 0 ranks in Combat Agility, 0 ranks in Improved Familiar, etc.). Nothing.

    The character did get 6/6 Trials of Mata Murum and 4/5 Keepers.

    I have since tried upgrading a long existing level 1 Wizard and hitting Upgrade Character from the Character Creation screen. Still the same outcome … no aas granted.

    I took a peek at Miragul server and created a character from an All Access account (cause that's what it takes). Creating a new character and logging in produced no AAs as well, but auto grant did work … because it's an All Access account.

    Since the Heroic is suppose to come with AAs per description, you borked something. Please fix.
    Yinla likes this.
  2. Lenowill Augur

    This happened to me recently as well when making an alt on Miragul. In that case, camping and logging back in gave me the message "Your skills have been increased to Heroic levels!" (paraphrasing) and that included AAs. However, I had AA Autogrant on at the time and am not sure if that was what made the server turn the character properly heroic, or what.

    In any case, it's definitely behaving oddly.
  3. GNOME_POWER Augur

    I will modify it so that it can only be upgrade with gold.
  4. Yinla Augur

    Got bored and created a new enchanter 1st January, went heroic on her from Char select when I created her. When she arrived she had no AA, so the hot buttons just came up as not available or something when accepting the game suggestions. Had to turn the auto grant on and level before she recieved them.

    Have you changed the auto grant from being on by default at creation to being off? I'm sure one of the patch updates a while back with some AA changes something changed to make all chars having auto grant turned on.

    My wizzy who has always had auto grant turned off (never needed it) magically had hers turned on. Along with other chars of mine who didn't have it turned on.

Share This Page