Game won't launch on steam!

Discussion in 'Player Support' started by Fellorin, Aug 10, 2017.

  1. Fellorin New Member

    So everquest has been working great for a while now, but ever since my windows 10 updated Everquest doesn't seem to be launching at all. When I click play on steam it says "running" but nothing starts up or plays at all. When I check the task manager it says that "Daybreak game company launcher" is running and if I were to end it then Everquest would stop running. I also tried to download Everquest from the website itself but no matter how many times I click download my browser loads and doesn't do anything. Does anyone know how I can fix this issue? So far I've tried a cleanboot, uninstalling and reinstalling steam and also a restart but nothing seems to fix this.
  2. CatsPaws Augur

    If its just since your windows 10 update then check your DX9 version since if windows allowed that to update it is the wrong one to run EQ - do some searching and something should pop up.
  3. Fellorin New Member

    looks like I'm currently using Dx12, I can't seem to find anything talking about dx12 and everquest.
  4. CatsPaws Augur

  5. Tavern New Member

    I am just going to let you all know this is something going on between certain ISPs and DBG Everquest/Everquest2 patch/file servers. People need to contact their ISP or DBG directly and let them know what is going on. I have a friend who can't even download the setup file from website, let alone have the game launch through steam. I personally tried to download EQII and can verify there is something wrong with either connection from me to the patch server or the patch/file server is just down on DBG's end.
  6. Fellorin New Member

  7. Fellorin New Member

    Also after checking the Everquest discussions it seems that other people have also had this issue since August 5th.
  8. Aursiia New Member

    It not only won't launch on steam (where I actually was finally able to at LEAST download it), but I can't even download the game, period, when clicking on the link on the EQ site to download the patcher.
  9. Tavern New Member

    Yeah , i just did a reinstall of windows 10 yesterday, had my brother in-law check and other friends also check. I can not download the game setup file, it times out. I try to use steam version the launcher doesn't even load , try to bypassed launcher for steam version -> connections has failed to servers. I have done everything on the forums and from their tech support page on this issue.

    I will show my tracert information.

    >tracert launch.daybreakgames.com

    Tracing route to vip0x058.ssl.hwcdn.net [205.185.208.88]
    over a maximum of 30 hops:

    1 <1 ms <1 ms <1 ms
    2 9 ms 8 ms 7 ms 142.254.213.9
    3 26 ms 21 ms 21 ms agg63.romeny0901h.northeast.rr.com
    4 12 ms 11 ms 11 ms agg62.esyrnydr02r.northeast.rr.com
    5 25 ms 23 ms 22 ms agg27.albynyyf01r.northeast.rr.com
    6 32 ms 31 ms 31 ms bu-ether36.nycmny837aw-bcr00.tbone.rr.com
    7 25 ms 25 ms 25 ms 66.109.1.59
    8 24 ms 24 ms 27 ms 66.109.9.145
    9 25 ms 25 ms 25 ms 6-2.r2.ny.hwng.net
    10 25 ms 25 ms 25 ms a10-slb001.ny2.hwcdn.net
    11 25 ms 25 ms 25 ms vip088.ssl.hwcdn.net

    Trace complete.

    I do not see any issues with my connection to the servers at all, so i know it's not on my end. H1Z1 works fine i can connect and patch perfectly, only seems to be a problem with EQ/EQII for me with installer and patcher.

    When trying to download the setup file from the website i get.

    launch.daybreakgames.com took too long to respond.

    HTTP ERROR 504
    Aursiia likes this.
  10. Rieannon New Member

    I can't log in either. Still running Windows 7, and it was fine yesterday. Today all I get is this message: Unable to download IDS_UNABLETODOWNLOAD
  11. Vaneksniper New Member

    This is a HUGE issue, FIX THIS ASAP Daybreak, ppl cant download your game(me as well)
  12. Fellorin New Member

    This is really pissing me off, Daybreak isn't doing anything about this. I even made a ticket and after a few responses they said it had to do with my internet! If it's just my internet why are other people having this issue too? I was super hype to go on agnarr this weekend and be there when kunark releases but I guess since daybreak isn't doing anything about this I'm gonna miss it all T_T
  13. Kelane New Member

    I am having the very same issues. I started a ticket yesterday but daybreak hasn't responded.
  14. Fellorin New Member

    Actually I just realised that this patch that is ruining everything happened on the same day that my windows computer was updating. So I guess it doesn't have anything to really do with my windows updating. Daybreak needs to fix this, its been 4 days since this issue has started and 0 progress has been made...
  15. Vaneksniper New Member

    Yeah they need to cut the BS saying it's our internet speed....I have the fastest internet you can get, im sure everyone has fine internet and that's not an issue....such a copout Daybreak.
  16. Fellorin New Member

    EXACTLY! I haven't had an issue with my internet since 2015 and now when I can't get into Everquest daybreak is saying it has to do with my internet? so coincidentally thousands of people are having the same internet issue and can't seem to play Everquest or install it at all on the same day for 4 days in a row? Seriously Daybreak has to fix this, Everquest 1 & 2 being my main mmo at the moment, this is really bugging me out. For the past 4 days I've constantly been looking for a solution. My weekend is already F%#ked!
  17. Bumblebuck New Member

    I took a month off from EQ and decided it was time to re-sub. I went to patch the 52kb download and it doesn't do anything (not using Steam for EQ). I submitted a support ticket and requested a refund. I also sent them a message regarding the issue via social media. Hopefully they fix it for all of you that are still waiting to log in. For me, I think I'm done and moving on to a different game.
  18. Fellorin New Member

    Yeah daybreak is really really bad at handling this issue. Last update we got on it was 2 days ago when they said they were working on a fix for it. I doubt they are even doing anything. I actually was planning on buying all access too like 4 days ago to play on Agnarr when kunark releases but I doubt that's gonna happen anymore. I swear if this issue goes on AFTER kunark releases then I am done with daybreak.
  19. Kelane New Member

    I got a response from them yesterday. They said it is an issue with their file stores and that they are working to resolve the problem...
  20. Kelane New Member

    and I was planning on playing on Agnarr too :(

Share This Page