Failed to load the graphics DLL

Discussion in 'Player Support' started by Fahgeta, May 20, 2023.

  1. Fahgeta New Member

    I have tried reinstalling everquest but this did not work. There were some errors that popped up on the DX install but those appeared to be the game trying to install older versions of DX files. I have taken a look at the other threads that mentioned DLL issues but those seemed to list a specific file. The error I am receiving says "failed to load graphics dll". Sorry if I am failing to see it is the same issue as the other DLL threads
  2. xukil of luclin Curator of a UI

    you need dx 9.0c. 10 and 11 don't include 9.0c so just because you have dx10 and dx11, dx9.0 games won't load. :eek:

    At least that's how it used to be.
  3. CatsPaws No response to your post cause your on ignore

    This is a new dll error. Not related to the old ones. They were supposed to push a hot fix thru the other day where if you just re ran the patcher then it would pick up the needed dll files.

    Yes, your error is the same just cause its worded slightly different does not mean the same fix won't work on it. It will. Don't uninstall/reinstall again. Just try running the patcher or doing a file verification. If those don't work then down load this which was posted as a fix by knowledgeable players.

    This is the link Strat79 put up that is for this issue. Click the blue download and then open your download and then export and then run the first one listed and it should run the rest.

    I am sure there is an easier way but I am kinda backward and it worked for me. Now on the other hand I logged in to another computer I have since that hot fix the other day and did not need to do any thing

    Here is his link
  4. Fahgeta New Member

    I went ahead and tried it and it did not fix my issue. Still having the same message.
  5. bard007 Augur

    I was getting this on an old Win7 Machine
    I just re-Install, DX9 (32bit) and DX9 (64bit) updates my video drivers with latest from NVIDIA .. that fixed it straight away.
  6. Fahgeta New Member