Equal and Apostrophe keys don't work in-game

Discussion in 'Player Support' started by Warik, Oct 22, 2012.

  1. Warik New Member

    Just downloaded EQ after several years away and noticed that my = and ' keys don't work in-game (they work fine outside of eq). How do I correct this?
  2. TSR-SeanF Augur

    Are you currently running WebRoot or GuardedID? These programs can cause keyboard issues with EverQuest when they are running simultaneously with the program. If you are not I would suggest that you make backups and then delete the following files:


    Also, back up the character configuration files by following these instructions:

    <CharacterName>_<ServerName>.ini (example jack_bristlebane.ini)
    UI_<CharacterName>_<ServerName>.ini (example ui_jack_bristlebane.ini)

    One or more of those files may be corrupt, causing these issues.

    If deleting these files does not resolve your issue, you can restore your backed up files and folders and retain your hotkeys, contact lists, and display settings.
  3. Falos Augur

    1.at your start menu open up your device manager
    2. click "Human Interface Devices" to expand the list
    3. right click Microsoft eHome Infrared Transciever
    4. Click disable
    5. If you see any other instances or options besides that that say eHome in them right click and delete them

    This should allow you to have full functionality with your keyboard in EQ and other various online games that share this problem
    Sonavaa_Bertox and Leerah like this.
  4. TSR-AlexS Augur

    Did the suggestions above fix your issue?
    Please keep us updated!
  5. AB_H'Sishi Augur

    I remember these issues come from a combination of TV card, IR receiver and Windows MediaCenter.
    In the old EQ forums was a very-easy-to-follow HowTo to fix that. I think it includes the change of the driver for the MCE IR receiver.

    Unfortunately, the old forums are gone or at least hidden, and so is this particular solution :( .
  6. TSR-AlexS Augur

    Let me see if I can find the old posts about it. I'll link it to you when I do!
  7. Sarkaukar Augur

    Certain keys on keyboard not responding in-game; can't figure out what the problem is.

    The issue is primarily the infrared remote control for the multimedia while for a few others it Logitech G15 software. Windows is overriding/not releasing those keystrokes (or allowing EQ to override it). There are workarounds which usually results in disabling the remote control.
    Unplugging the IR.
    Shutdown setpoint.exe (Logitech software)
    This is most commonly caused by having the Microsoft Media Center infrared device. Even if you don't have a Media Center version of Windows installed, just having the infrared receiver can cause problems.

    I finally found (again) the web site that describes the "best" fix for this (best in that it still allows use of the remote, but also allows typing punctuation characters in games, etc.:

    1. Go into Device Manager -> Keyboards.

    2. Right-click "Microsoft eHome MCIR 109 Keyboard", choose "Update Driver" ("Update Driver Software" on Vista and 7).

    3. Choose "Browse my computer for software" (XP users tell it not to install automatically and say you'll specify the location, then when it asks you where you would like it to search for drivers choose the option to choose from a list) then "Let me pick from a list of device drivers on my computer".

    4. Make sure "show compatible hardware" is checked, then select "HID-compliant device" and click next. Click any remaining "OK" or "Finish" buttons after Windows has installed the driver.

    I just realized I had this problem after tonight playing in Underfoot.
    Last week or so, I installed a WinTV HVR 2250 in my desktop, that came with a remote for Media Center.
    Interestingly enough, it installed Microsoft eHome Infrared Tranceiver, as a Human Interface Device, which also installed 3 keyboards (Microsoft eHome MCIR 109 Keyboard, Microsoft eHome MCIR Keyboard, and Microsoft eHome Remote Control Keyboard keys), all found under Device Manager.
    Little did I know that it was the culprit all along.
    I use a USB Keyboard/Mouse combo using a receiver, since I use them wirelessly. The set I have is Microsoft Wireless Desktop Elite (Microsoft Wireless Desktop Elite Keyboard with Wireless Intellimouse Explorer 2.0).
    I do use the remote control that my TV Tuner card came with so I can be lazy and use it with the IR receiver the tuner came with, but I did not want to loose that functionality.
    So, since I do not own any keyboard that has anything to do with Media Center, all I did was this (and was surprisingly easy):
    1) Open Device Manager
    2) Click on "Keyboards" to open the tree.
    3) Right-Click on "Microsoft eHome MCIR 109 Keyboard" and choose "Uninstall", then click "Ok".
    4) Right-Click on "Microsoft eHome MCIR Keyboard" and choose "Uninstall", then click "Ok".
    5) Right-Click on "Microsoft eHome Remote Control Keyboard keys" and choose "Uninstall", then click "Ok".
    6) Click on "Human Interface Devices" to open the tree.
    7) Right-Click on "Microsoft eHome Infrared Transceiver" and choose "Disable", then click "Ok".
    You do not have to reboot.
    Now if you ever DO get a keyboard that uses Media Center, you can then go back and Enable that device, which will reinstall those keyboards again after rebooting.

    Actually, rather than disabling the device, there is another workaround if you want to keep using it.
    In Device Manager under Keyboards, update the "Microsoft eHome MCIR 109 Keyboard" to a "HID-compliant device"
    Here's a screenshot: http://img218.imageshack.us/img218/1909/tilde.png
    Restart the game if you had it open, and presto, now you can type tilde's and still use your remote.


    Just to add, the following programs has been reported (at the time of this post 1/29/12) to affect keyboard behavior:
    Comcast/GuardID (GID)

    Replacing Webroot would be another fix [IMG]
    Does Webroot still have Gamer mode? What happens when it is activated?
    Most players who have posted are simply removing Webroot. It is possible some are keeping it but have submitted tickets to Webroot, simply not posting it.
    To note, keyboard issues between Webroot and other games have been reported.

    Message edited by Sarkaukar-Povar on 03/23/2012 02:14:27.
    Corwyhn Lionheart and Leerah like this.
  8. Kirbane Augur

    that is a creepy eyeball, looks like its reading all the posts at once!
    Sarkaukar likes this.
  9. TSR-AlexS Augur

    Lol, that's Sarkaukar's signature signature (If that makes sense).
    Sark, thanks for your assistance once again.
    Op, let me know if your continue to have issues so we can further assist you!
  10. Leerah Augur

    This was particularly true with Vista users although some WinXP Pro people had it too.
  11. AB_H'Sishi Augur

    For me (Win7 Prof 64Bit) the issue was caused by the MCE IR receiver driver and Sarkaukar's HowTo is exactly the solution I mentioned (thanks for bringing it back into here from me too :) ).
    I don't know why EQ has some trouble with special keyboard drivers.


    Speaking of problems with keyboards ... why is EQ 1 unable to produce special language characters, e.g. german umlauts ("ä, ö, ü, ß"), french accents / trema's ("é, à, ô") . A try of using them just produces a square.
    Not to mention, the [^] key can be used as hotkey ...

    If they're placed offline in macro's (like /say äh .. öhm ...) the umlauts are displayed correctly.
    EQ2 players can use them in serverwide chats or cross-server tells; the umlauts appear correctly in EQ1.

    So, why (just?) EQ1 has this problem and why did the umlauts work some years ago with german- or french-languaged clients when Ubisoft operated the french and german servers?

  12. Sarkaukar Augur

    Take it the next step, set it as your desktop, either expanded out, or even more so, tiled (shudders). Did that one day for fun and had a friend's little girl here. She ran out screaming bloody murder that the eyes were going to get her...my ribs were sooo sore from laughing..
  13. Sonavaa_Bertox Elder

    This instantly fixed my problem. Thank you for the fix!
    BoomWalker likes this.
  14. Koutarou Elder

    EQ has been unusable with Japanese keyboards for years and years.

    Keys like colon don't work, so nopasswordedchannelsforjoo.
  15. Kirbane Augur

    hahahaha well played sir
  16. Diptera Augur

    On the "international" front, I remember that many years ago, I had to replace the "keyboard.txt" file in the EQ folder with a "UK-friendly" version, so that some of the keys produced the correct characters (the 'usual' @ and " , and # and £ differences between our keyboard layouts).

    I don't know if there are similar keyboard.txt files to help the Europeans with their accented characters?
  17. AB_H'Sishi Augur

    *removing the dust from this thread here*

    About the keyboard.txt Diptera mentioned ... we Germans had such a file when we played on the former Ubisoft server "Kael Drakkal". We were able to use all german-specific characters; I guess something similar went for the french people.

    Unfortunately, this keyboard.txt file got lost some day :( . I guess not even SOE has it anymore ...
  18. Nennius Curmudgeon

    Anyone found a solution to the problems the OP had. I am, for now, using a Dell Optiplex with Win XP on it. Out of date, I know, and the equal and apostrophe keys do not work in-game. No problems elsewhere. I deleted all of the hardware related files as indicated above and no luck. Specifically, I deleted:

    All meaningful suggestions welcomed.
  19. Nennius Curmudgeon

    BTW, nothing international about my system.
  20. Nennius Curmudgeon

    No luck yet, but I do have two entries for a keyboard on device manager. Will delete them both and reboot and see what happens.