eqgame.exe will not run after hardware upgrade

Discussion in 'Player Support' started by Cannikin, Apr 18, 2017.

  1. Cannikin Elder

    I recently replaced the following components on my computer:

    Motherboard: Z77 chipset -> Z270 chipset
    CPU: i7-3770 (Ivy Bridge) -> i7-6700k (Skylake)
    RAM: 16GB DDR3 -> 32GB DDR4

    All other hardware components are the same as before when EQ ran fine. I've been running Windows 7 64-bit. Now when I try to run EQ nothing happens, whether through the LaunchPad or running eqgame.exe directly. There is a process in the task manager of "eqgame.exe" which stays at around 3.7KB memory usage and doesn't do anything. No memory changes, no I/O, no CPU utilization.

    I've tried uninstalling and reinstalling EQ. Same thing. I then did a clean reinstall, deleting every file, including all .ini and appdata on OS drive, and scoured my registry for any entry I could find for "everquest" or "eqgame". Still didn't work. I then downloaded EQ through Steam. No go.

    Every other game I have works fine, including Planetside 2, another DBG game, so it is specific to eqgame.exe.

    Other things I noted:
    - "patchme" shortcut does nothing, nor any other method of running eqgame.exe without the launchpad.
    - I had previously set CPUAffinity0=-1 (all cores) in eqclient.ini. That eqclient.ini is long gone, but I noticed that eqgame.exe still has affinity to all cores by default in task manager.
    - Setting eqgame.exe to run as administrator gives an error in the launchpad about permissions.
    - Doesn't seem to have any problem with my firewall.

    I'm out of ideas on what to do now.
  2. Ghubuk Augur

  3. Cannikin Elder

  4. Corwyhn Lionheart Guild Leader, Lions of the Heart

    Good suggestion though it sounds like he didn't change hard drives which is the perplexing part EQ Could be some issue caused when upgrading drivers. Did you uninstall the various drivers from your old motherboard before installing the new one? Why that would effect eq I don't know but it would be more likely that software changes are the culprit. I don't see the hardware changes as anything that would have any affect.

    I would double check your firewall settings. If Planetside and other DB games work maybe somehow EQ got blocked there somehow.

    Btw Hi Cannikin :)
  5. Cannikin Elder

    Heya Cor! Thanks for the suggestion. I double checked my firewall and manually set eqgame.exe to have full permissions, still doesn't work.

    The fact that the eqgame.exe process shows 0 I/O activity, 0 CPU activity and minimal memory usage suggests some kind of low level stoppage preventing the program from executing at all. Time try some more complex solutions. Hopefully it doesn't come down to something drastic like installing Windows 10 for full Skylake/Z270 support. /shudder
  6. Cannikin Elder

    OK, I solved the problem. It appears to have been some kind of conflict with the built in audio on the motherboard. Disabling it and all the software associated with it lets EQ run (either that or one of the seemingly unrelated, non-essential services I disabled while I was at it). Weird that something like that would cause a complete failure to execute eqgame.exe instead of some kind of error message. Oh well, I use a dedicated sound card anyway.

    Thanks guys for your suggestions.
  7. smash Augur

    Run as admin ?
  8. NameAlreadyInUse #CactusGate

    I also use the onboard audio on my mobo (Asrock Z77 Extreme4), and I have a "Line In" device connected to the audio out from another monitor connected to my xbox (to play xbox audio, since the monitor doesn't have speakers). It works great, except when I run EQ: then I get static on the Line In device, usually bad enough that I mute that device while I'm playing EQ. But I don't have this problem if I'm watching Netflix or playing other games on my PC, only EQ. <shrug>