DirectX 11 API Port is on Test Server!

Discussion in 'News and Announcements' started by Angeliana, Sep 12, 2023.

  1. phattoni Augur

    that should work fine, the old school asus pen computers i use are not fine however, but they are also 10+ years old lol.
  2. Herf Augur

    I'm trying to log onto test on the machine listed above. The machine has DX-12. EQ is telling me "Error: Failed to load the graphics DLL!"

    Shouldn't the game load DX11 if it needs it?? I'm confused a bit about how this is supposed to work

    Hmm I was just reading the instructions given to get to the test server. Apparently it's more involved than just selecting "Test" in the loader. I'll have to try a few things.
  3. Lodestar The Undefeated

    Developers: Post from the bug forums below. I can confirm this also happens to me. I have all of the newest hardware currently available running a fresh Windows 11 install, and properly setup (4090 RTX @ 3.1ghz, 7950X @ 5.95ghz, Crucial T700 SSD @ PCIE 5.0 x4, etc). Therefore this DX11 issue is confirmed, and needs to be root cause analyzed to understand what's causing this consistently inducible crash in House of Thule, to identify any other game locations where the same crash also occurs. My test INI file is using defaults with nothing changed. Additionally, "Return Home" is greyed out which means the only way to get out of the crash loop is to execute a new /testcopy (which I can't do for another 8 hours, so alpha testing on Daybreak's behalf is suspended). This has also been reported for Plane of Tranquility and Frontier Mountains by the original poster in the bug forums (I've not been able to confirm POT/FM on my end yet).

    "Category: Other [Crash]
    Date/Time: Wed Sep 13 00:50:07 2023

    Character: Level 87 Magician (Main)
    Zone: House of Thule
    Location: Beastling of the Unknown (don't have the exact /loc, sorry)

    Description: Since the latest DX11 update, I have found a location in the first floor of House of Thule that causes my client to crash repeatedly. It's right outside the gate at the bottom of the stairs leading into the room with the "beastling of the unknown". This happened on multiple clients and causes a crash loop that I could only fix by using the "return home" button."
    Hobs likes this.
  4. Herf Augur

    Bug: My windows 11 Pro machine, on a mini PC, cannot run EQ on Test server.

    dbg file shows the following messages:

    Loading graphics DLL.
    Unable to load EQGraphicsDX9.DLL (126)
    Failed to load graphics DLL in WinMain(), exiting!

    Notes: on this same computer, running Live, everything works just fine. I have followed the instructions to copy the Live install to a Copy location, going into the Copy, running the Launchpad and selecting Test vs. Live. But I get this error. Rebooting has not helped. I'm not sure what's wrong given that Live works just fine on this computer.
  5. Cairbrae Developer

    Hobs likes this.
  6. Kompacte_of_Test Journeyman

  7. bobokatt Augur

    I have tried everything. I can pretty much confirm that if you are on Windows 7, and have the SP1, and have done all the updates for DirectX, have updated all the dll libraries, have your GPU drivers up to date, nothing works.
    My EQ life has been the SAME computer with the SAME directory that I have ported over to various computers sinc 2001.

    If someone here has or is on Windows 7 and got this DirectX 11 port to work, PLEASE let me know how.
    I have NEVER had to do anything on ANY other games I play. Everything just works for every other game with my current hardware and Windows 7. On test, NOTHING works. I get the screen that loads and then says PLAY, HIT PLAY and it just goes away.

    My DXdiag shows Directx 11, latest drivers yada yada.

    EDIT: I was not correct. I have UPDATED my hardware. I have NOT being using the same COMPUTER for 22 years. I have however used the same EQ "folder". My hardware for this Windows 7 computer is an Intel 2700K with 32GB of RAM, SSD and an AMD RX 480. There is NO reason that this system CANNOT run EQ and it has been for ever (even 6 accounts at max and 4K).
    Dear God give us a TICK to choose DirectX 11 ON THE LOGIN SCREEN (ON OR OFF).
    Herf likes this.
  8. bobokatt Augur

    Can anyone on your DEV team actually TEST a system using Windows 7? Do not just say you must need SP1. This is not working. I cannot be the ONLY one. This is an OLD game. Many of us are still on old legacy systems and that is why I LOVE this game. Do not need a 4090 and a 13900KS running Win11.
  9. Mysl Augur

    Using viewport, the PC/NPC names shifted from the model.
    Without viewport, the displayed name is centered with the model

    With /viewport 200 0 1400 1060 1, the name shifted by about 200 pixels to the right.

    Edit. The images I copied into this is not showing. :(
  10. Herf Augur

    I sincerely hope that before these new features are unleashed on us that any and all install requirements are coded into the game so we don't have to search the web for downloads.

    For the life of me I can't understand why a new'ish Windows 11 machine running DX12 has to download DX9 to play EQ on Test.
  11. Telstar New Member

    I 3 box - my 3rd machine is a laptop with integrated graphics it only supports up to Directx10 - does that mean after the patch that machine will no longer be able to run EQ? Its win 10 64 bit
  12. I_Love_My_Bandwidth Mercslayer

    They are testing. Using your Windows 7 system.
    Metanis, Skuz, bobokatt and 2 others like this.
  13. Nennius Curmudgeon

    Sturmlocke, Metanis and B0HICA like this.
  14. Doranur_Aleguzzler Filthy Casual™

    Skuz likes this.
  15. Nennius Curmudgeon

    Bah. Oh well.
  16. Jedis Arch Mage

    If you are fresh installing EQ, it does install DX9. If you are copying the directory, then yes, you need to find your own copy of DX9 to install. For this reason, I keep the installer in the EQ directory so when I copy it to a new PC, I can run the installer for DX9.

    It makes sense that Win10/11 do not come with DX9 by default. It's ancient.
  17. Tarvas Redwall of Coirnav, now Drinal

    It's probably a good thing that EQ is moving away from supporting OSs that are no longer receiving security updates.
    Sturmlocke, Metanis and Skuz like this.
  18. Herf Augur

    Tell me more please! I did a fresh install on the machine when I installed EQ last year and it works fine normally. For test I followed the instructions and copied the entire EQ folder, reset the login to test and tried to log on, with failure.

    I'm saying that when they release this on Live they need to download and install DX9 since it is apparently needed by EQ for some reason.
  19. Fideles Lorekeeper

    R.I.P. my old boxing laptops from 2011 with their Intel HD 3000 graphics.

    My ASUS Vivobook with a Celeron N4020@1.1GHz and Intel UHD Graphics 600 running Windows 11 is loading up Test just fine. That seems way underpowered compared to even the minimum REQ's in the first post.
  20. Riou EQResource


    Pretty sure their min requirements are just the worst PCs they had access to to see if it still runs
    Hobs and Nennius like this.