Fixed Internally Desktop Windowed mode position issue

Discussion in 'Bug Reports' started by Korwiin, May 15, 2024.

  1. Pizzanomicon Augur

    Thank you so much for this. I was freaking out that the method I've been using for the past 4+ years to BFS EQ in an acceptable manner was somehow completely broken. It makes no sense.

    Now I just gotta hope my custom UI will not cause anything to crash.
    bobokatt likes this.
  2. aiha Saryrn [Bertox]

    Noticed that if you run the script at server select it will revert back to 0,0 after alt-tab. Think the server select is a bit of a special child or something. Thanks again for the script!
  3. Jedis Arch Mage

    I am also having this issue on my machines. I am setting the following so I can use windowed mode and position the title bar off of the screen. It worked fine on Windows 10/11 until the patch this week.

    WindowedModeXOffset=-8
    WindowedModeYOffset=-31
  4. Jedis Arch Mage

    The server select issue has been there for years unfortunately... if you get booted to server select or swap servers, you need to restart the client after restoring the Window offsets.
  5. Pawstar New Member

    Windows 11, using PowerToys / FancyZones ... Switching between EQ windows is causing them to pop-out of their zones.

    FancyZones / EQ worked great till the current patch - please fix!
    Kendeth likes this.
  6. Indomini New Member

    I'm experiencing this issue on my end. Please Fix before TLP launch!!
  7. Gorehammer Lorekeeper

    I would like to kindly request the devs do a little something extra to compensate for this setback (pun-intended) affecting so many players... Please make a borderless windowed mode easily clicked in Options.

    This is the way. :cool:

    (But yes, in the meantime we'd like our negative Offsets to work again. And as others mentioned, please don't make us wait another month without, like we had to do when chat filters were recently broken so we had to change them every time we logged a character on.)
  8. Shalom Quillmane Bane

    Glad this has been confirmed - I've been playing in Full Screen mode and man I can't wait for this to be fixed. Minimizing EQ every time I click out of the game is getting old fast. Especially when you use OpenDKP site for raiding constantly clicking on a webpage etc
  9. Greig New Member

    Has it been confirmed they will fix it where we can click on the other monitor while in full screen mode with the game minimizing like we were able to do before this patch? Because, I hope so, it has taken some joy out of the game because i feel handcuffed in full screen mode.
  10. Shalom Quillmane Bane

    Agreed there that full screen mode makes you feel handcuffed. I don't think they've communicated how they intend to fix it but I guess its a confirmed bug is all. Which means it will be addressed at some point I assume, just how we don't know.
  11. JolineSZ Augur

    Same problem here.
    And the worst is that it also destroys my viewport settings and the taskbar does not hide behind windowed mode window anymore. No matter if i check mark it or not. I have to change it to hide in desktop mode in Windows itself.

    Please fix this asap.

    So some people do not crash anymore but a lot of others have broken widow positioning. /sigh

    Forgot one thing. it is not working for minus value, with plus values in the offset you can move the window outside the screen, means lower right corner, then it does not swap back- upper left corner, no chance anymore
  12. Galvanize Elder

    Please God borderless windowed mode, no more windows XP era title bar junk
    Sunawar likes this.
  13. Peter_The_great Elder

    Ah, more got the issue I deal with. Good to know.
  14. Tyreel Augur

    I 'fixed' this by going to Windows "Snap Settings" and turning Snap windows off. Not a great solution but it works for now.
    Peter_The_great likes this.
  15. Pizzanomicon Augur

    Eta when this is getting fixed ?
    xcitng likes this.
  16. Xianzu_Monk_Tunare Augur

    Problem with that is twofold, one, the amount of space that it allows to be off screen is less than what it previously one, and, two, that you have to move it off screen every time. Before the last patch, the position was remembered even if you had snap turned on, so you had to do it just once ever. If the screen turned off you used to be able to double click the title bar, it would maximize, then double click the title bar again and it would revert back to being off screen, but now it doesn't.
  17. Shalom Quillmane Bane

    Well, it's been a while and playing in full screen sucks. Minimizing EQ every single time I need to send a discord message or bid on an item is really getting old. Hopefully they fix this soon.
    Xianzu_Monk_Tunare likes this.
  18. Vumad Cape Wearer

    I have had a similar but different issue. I have a laptop and when I plug it into another monitor to add a display, EQ will attempt to go back to that non-existant display the next time I try to log into EQ. EQ also goes nuts when switching between full screen and windows with using an extended display. I didn't spend a lot of time troubleshooting it.
  19. Cairbrae Developer

    I think the main OP topic is fixed internally and please login to Test server after the June patch today to see if window positioning meets your expectations.

    On Windows 10/11, the Snap Windows feature (in Settings > System > Multitasking) moves and resizes windows automatically and it's enabled by default. I recommend turning this off if you want to position your game window partially offscreen.
    xcitng, Dax74 and Schadenfreude like this.
  20. Razzy Journeyman

    Can confirm setting WindowedModeYOffset=-31 works on Test now.
    xcitng and Schadenfreude like this.