Click Play nothing happens

Discussion in 'Player Support' started by Task, Apr 19, 2019.

  1. Task New Member

    I am trying to login into the game and when I click play off the launcher it does nothing. Anyone else having issues?
  2. Rowdey New Member

    Are you on Selo by chance? Because it just crashed and is down.
  3. Joules_Bianchi Augur

    try right click / run as administrator, or perhaps you're trying to get on Selo's which just crashed?
  4. Task New Member

    I am on Agnarr. I will try the admin. thank you.
  5. Task New Member

    Oddly still the same after run as admin.
  6. Artagna New Member

    I think i have almost the same problem with you.
    So i just finish installing EQ from steam so i'm thinking i'm all good and ready to play. But when i click the play button on the launchpad it just open the EQ window for couple second and close it self so does the launchpad, well the first time it happen i thought it was normal, so i just left it there and to other stuff but when i came back nothing happen, and so i tried again and again but i keep repeatedly closing on itself.
  7. CatsPaws Augur

    More than likely this is because you need Direct X 9C - yes I know you have the latest and greatest Direct X but it may say it contains 9C but it doesn't. There are many posts on these forums about where to download the right 9C. Direct X controls the graphics. There is a conflict happening between the game and the Direct X in your machine so the screen closes. https://www.microsoft.com/en-us/download/details.aspx?id=8109

    You can also try this:
    Right click the EQ shortcut icon. click properties. click compatibility tab. check the box for disable fullscreen optimizations. check run as administrator. the problem is with the fullscreen optimizations causing it to not launch. you are checking run as admin just to prevent other issues.

    I dont know about using the steam version. you probably just need to find where the EQ icon is on your pc. it should be in the c:\programfiles\steam\steamapps folder somewhere.
  8. Artagna New Member

    I think it's not about DirectX stuff, because before this i have run into another one i think it's the Failed Graphic DDL or something i forgot what it called and i already download thru the link that you gave.

    Now i with that second solution that you talk about. When i right click at the icon on my PC in the properties there's no Compatibility tabs though.
  9. CatsPaws Augur

    It is all about your graphics. :D Your previous issue with the Failed Graphic DDL was fixed with the 9C. And this is another graphic conflict now.

    Could be the server mis connection the last few days - lots of folks getting stutters and lag and my music was on and off all over the place in EQ only, but now has cleared up today with the better connection.

    But for this one - Do you have windows 10? Cause that is where the disable fullscreen is. You can also try the option to run in windows 8 compatibility if you don't have the disable option available and see if that helps. If not just change it back.

Share This Page