Fixed Internally Changing Characters/Servers - Someone logged into your account error

Discussion in 'Resolved' started by Troutfest, Aug 22, 2020.

  1. Thunderkiks Augur

    Looking good here as well. I tried a few different accts and a few different characters several times and all went to character select. Fingers crossed you solved this.
    niente likes this.
  2. niente Developer

    If you still have this issue after the Live patch next week, please let us know.

    I added more diagnostic things that will go live in February but if it is still bugged next week we can expedite a different method of fixing it.
    Thunderkiks and adetia like this.
  3. yepmetoo Abazzagorath

    It happens every single day to me. It has to do with running multiple accounts (not at same time necessarily) on the same pc, and it "locking" somewhere in a default setting to 1 account. So like, one account works fine. But on second account, if I camp out, it goes to server select, gives the whole spiel. You can tell its that because it always defaults on the old login screen it boots you to, to that one account it is defaulting to.

    Will see next week!
    Knifen likes this.
  4. Jedis Arch Mage

    This is not entirely accurate. The "locking" you are referring to is because the old login (patchme) caches the last used login name for the account that last logged in with the old login ui. The credentials that are passed through via the Launchpad are not cached in the ini file. It is merely reading the INI file to show those credentials on the old login screen. When you camp to server select, you already have an active session that is identified as what you're logged in as, not the value read from the ini file.

    I only play one account on a PC, and it randomly happens to me. It happens when I /camp server and when it returns to the server select, it shows someone else has logged into the account. Clicking ok exits to the login screen. Then, always the next login (to any account) always says failed. It takes a second login for it to actually send the credentials and try to login. Validated by typing in a wrong password on the first login and it is not recorded or even shown that there was an invalid login attempt.

    My initial suspicion was that it had something to do with my IP address changing (I use a multi-wan router), but it only happens on the same two PCs.

    I tried locking the EQ subnet ( on those same two PCs to a single WAN, but it still occurs. It is possible that the login server is in another subnet that I need to add, but again, it only happens with those 2 PCs and not on the other PCs I play EQ with.
    Mukkul likes this.
  5. yepmetoo Abazzagorath

    Not true. Not at all what is seen. And if you type in the wrong password at the old login screen it definitely tells you how many times you had an invalid attempt. Not sure what you're seeing, but it isn't what I'm seeing. Definitely is irrelevant to IP address.
  6. DragoonRuin New Member

    It most Definitely can also happen to people not running multiple accounts on a computer. I only box a duo on Mischief, which is True Box, so I use 2 laptops, to run 2 accounts. Never logged into 2 accts on a single machine at all.

    And this happens to me also 5-6 times a week probably.
    Elyssanda likes this.
  7. Thunderkiks Augur

    I true box all my characters and it happens ever day to me on all the computers. Its looking great on test though. I have tried many many times and have always gone to character select now.
  8. Jedis Arch Mage

    Sounds like user error and not understanding how the login process works.
  9. Mukkul Augur

    When this bug occurs and you get kicked to server select, attempting to reload the server fails and you get kicked back to a log in page. Attempting to log in always fails the first time, and it does NOT count as a failed password. Second attempt to log in succeeds. THEN you can finally join the server.

    This problem exposes multiple bugs. They could fix the one bug, but it would only mask all the other bugs that are evident in this chain of log-in related errors.
  10. Tegila Augur

    nope. nothing to do with multiple accts on same pc. happened to me last night on 2 diff accts..but each is on their own computer. Wasnt from a /q or fastcamp either, but trying to get back online after resetting my modem randomly, almost 10min later first it said i still had a character logged in (LOL that long later..i went to reset the modem after all my netstat bars hit 50% or below) when i got back half were just offline half were at serverselect. First attempt at getting back in i got the "char still in world" message, so i kicked, then it failed went back to login screen on 2. Those 2 then said been a login by someone else, but didnt say there was still a char in world.
  11. Jedis Arch Mage

    It looks like all of the login servers (Beta, Test, Live) are all in the subnet, so my suspicion is incorrect. Multi-WAN routers / IP address changing should not be relevant in this case.


  12. Scila Augur

    It happened over the weekend to my frequent flyer account twice. I run 2 computers - 1 account on each one. It will never fail to happen on one, once in a while it will happen on both back to back. It doesn't have anything to do with 2 accounts on 1 computer. Both accounts I stopped use the button that will connect that says what server and use the one above it. It also doesn't matter whether I close from the char select using the x or back all the way out correctly. It doesn't matter whether I have a fresh reboot or use the same instance without a reboot. It also doesn't matter which character I'm moving between whether it's my main to an alt, trader to an alt, alt to another alt, etc. I use the camp button not /camp.

    I'll keep an eye on it after this patch and keep the devs informed.
  13. Thunderkiks Augur

    This is looking good for me. I normally would have this happen several times a day on several accts/pc's and I played quite a bit Wed through Saturday and never had this issue. It looks to be fixed. Thank you so much for looking in to it and fixing this! <3
  14. Mezacor New Member

    I am also no longer seeing this issue either

    This was such an annoying bug. Biggest QoL fix in a long time in my opinion.

    Great job tracking it down and resolving it!
    Thunderkiks likes this.