Can't buy expansion on website

Discussion in 'Player Support' started by MeToo, Dec 13, 2017.

  1. MeToo New Member

    Title says it all. I just get an error when I try to click the buy button with the price for the expansion. Guess you guys don't want my money.
  2. Brutalis-trak Journeyman

    yup basically me and 3 other friends have same problem no matter what accounts we try it refuses to sell to us ... maybe a sign from god that i shouldnt buy lol
  3. Weebaaa Augur

    Yeh.
    Maybe we'll try after the patch tomorrow
  4. Artyran New Member

    When I get to the server screen it says I own 21 of 24 expansions. When I click on the DB button in game and go to the website page and try to buy the ROS expansion it brings me to a page showing all the options but they are all grayed out and the page says I own all available game content.

    What Gives??????
  5. CatsPaws Augur

    Well if you didn't buy them in the past then its a bug but if you did buy them in the past its a bug.
  6. Sarahrain New Member

    The purchase seems to work fine if you are not logged into the game when you go to the website to make the purchase. Simply being logged out of the game has solved this for several people that I know.
  7. Artyran New Member

    I will try that now.
  8. Artyran New Member

    Nope did not work.
  9. Sarahrain New Member

    Artyran your situation is different than the others. the solution i posted above works if you are getting the 'error' when clicking to purchase. In your case with things grayed out, I would suggest submitting a petition to resolve your specific issue.
  10. Artyran New Member

    Petition sent
  11. Rashod Lorekeeper

    Try a different browser, heard reports from guildies last night that they couldn't buy it. I think it was Firefox that wasn't working for them.
  12. Artyran New Member

    Yes that was the problem, Daybreak asked me for a screenshot of the problem and then returned with the idea of trying another browser. It worked just fine with IE. For some reason it does not work with firefox.
  13. Skysoldier New Member

    Hey Daybreak .. WHY CANT I BUY ROS !?!? Why is the site up !
  14. Whylde New Member

    I have the same problem my wife tried to buy the new xpac for me but she cant because of that system error thingy there anybody can help out and figure it out? thx in advance
  15. Starry Journeyman

    Well had to wait till payday to get ROS go to purchase ROS and get this message
    We have encountered a system error while processing your request.
    Please try again later.
    We apologize for the inconvenience.
    If you continue to encounter this error, please contact Customer Service at https://help.daybreakgames.com

    WTH!! tried the logging out of game thing also and no go starting to rethink my purchases
  16. Starry Journeyman

    Pretty Sad i had to Download a new browser to purchase expac =(google chrome)
    Yinla likes this.
  17. Bay12345 New Member

    chrome didnt work for me

Share This Page