anchors failing

Discussion in 'Player Support' started by svann, Feb 19, 2017.

  1. svann Augur

    Two of my characters have anchors that no longer work. The anchors are still placed in the guild hall but when I activate the anchor transport devices it tells me "Your transport to anchor spell failed because no placed anchor of the required type was found".
  2. Malbro Augur

    Could be it was put in storage by someone?
  3. svann Augur

    No, when I shift-i it says they are placed, at least on one character.
    On the 2nd character I picked it up but cant place it back down because he doesnt have add item access, so Ill have to wait till the guild leader gets on to set my permission and then see if replacing it fixes it.
  4. Blackjaw_SolRo Lorekeeper

    I have the same issue (AB server); not sure if it started before or shortly after last patch. My primary anchor on my property still works fine, but my secondary anchor inside the Grand Guild Hall does not. Same error message as in the first post. I picked the anchor up (inventory) and placed it again, no difference.
  5. Lynnia Augur

    the plot is all caught up on rent?
  6. svann Augur

    yes
  7. svann Augur

    Picking it up and placing it back down seems to have fixed it, but this is the 2nd time Ive had to do that and I hate to keep bugging the GL to fix my stuff. Something about permissions to add items.
  8. CatsPaws Augur

    2 things needed for anchors in Guild Halls to work right. The first is the guild leader must give your char permission to interact with the guild hall under guild plot management. The second is that after your given permission that you are a paying subscriber. So if your free you do not have the ability to use the hall to add/remove/interact with items and you will loose the right to have the anchor there if your subscription lapses and you will need to get permission again or if the guild membership is changed somehow - either thru a game burp or the leader playing around. The game was recently turning pay players into free ones then back again so that might have caused it or when whole guilds were dropped or neighborhoods were taken down. Lots of possible reasons. You will get a "don't have permissions" error on both ways so no way to know for sure.
  9. Raccoo Elder

    I had this problem on one of my characters a few days ago. I also was able to fix it by picking up and placing the anchor again. Another person in my guild had this problem and said they were unable to fix by using this solution.
  10. Derka Journeyman

    I have had this issue on my main since last patch. Both no longer work in guild hall, only on my housing plot. Not a permission thing in guild, they have worked there for years and I sub. It also happened to a few alts but replacing them fixed it. I petitioned it and Dunbar told me to delete some configuration files to try and fix it but no luck. Just an assumption but by fixing the guild halls for others, it broke anchors :(
  11. Daktarr Journeyman

    I just started having this issue with my AETL GH anchor after the last patch. I tried picking up the anchor and replacing it, logging, zoning. The only way I can get it to work is put it in the yard. Then it works fine. Other wizards in my guild are not having any issues.

    Daktarr
  12. SonOfABiscuit Elder

    Still having this problem.
  13. TenkenTurtle New Member

    This is happening on two of my characters It temporarily fixes it when I pick up and replace my anchors in the Guild Hall. But if I log off and log on again it fails.
  14. Velisaris_MS Lorekeeper

    Ok, I think I've fixed my anchor problems. Of course, now that I've said it, they'll probably stop working again. :)

    I don't know if you need to do all of these steps, but this is what I did for multiple characters and it seemed to work:

    1. Have another character mail your anchors to you (I don't know if this does anything, but I could never fix the problem just by picking up the anchors, so I tried something else; it may also be that you need to have ALL of your items mailed to you, I'm not sure)
    2. Hit Shift + i and click the layout tab; delete ALL layouts for your character relating to that real estate zone (it'll have the zone's address attached to it) and all of the layouts that say "Auto (character name) (server name)" (one of my characters had nearly two dozen layout files, while all the others only had a couple)
    3. Place one of your anchors
    4. Check your layout files; if it made one with just the character name and server name, try your anchor; if it works, place your other anchor and you're probably good to go at this point; zone out and try your other anchor
    5. If you get a layout file with the real estate address after you place your first anchor (or it still won't work with the standard layout file name), place your second one and then delete the new layout file
    6. Zone out and test your anchor; if it works, you're probably good (you won't have a layout file listed for that character, but it doesn't seem to matter); you might have to repeat this process, or just delete the layout file again, if you place new stuff in the real estate zone

    I've tried this with multiple characters that had non-working anchors and it *seems* to have fixed the issue. They continue to work during that log-in session and then work again after I've logged out for several hours and log back in. The problem seems to be with the layout files themselves. Not having one or having one that's simply listed with charcter and server seem to be ok. As soon as a layout file gets created with an address, that's when the anchors stop working, at least in my case. There seems to be no reason as to why it creates one with an address or one without. Some of my characters had a new, address-less, file created while others got the one with the adress. Guild status/permissions didn't seem to matter for the characters

    If you're having an anchor issue, feel free to try my fix. I don't know if it's a real fix or what, but my anchors all work now.
  15. Malbro Augur

    Is there any way to disable the auto-layout feature?
  16. Malbro Augur

    I just tried this on two of my characters so far. Seems to have worked. Can't believe the crap load of auto saves in the plot layout window.

    I just tried my anchor on a character that I had just deleted the auto save guildhall entry. It worked.
  17. Malbro Augur

    An update. On two of my characters, I was able to just delete the plot auto save entry and they worked. For the rest, I had to actually pick up the anchors, delete the auto save entries after placing them.
  18. Velisaris_MS Lorekeeper

    My main character (Velisaris) had nearly two dozen auto save entries, in addition to two address entries (the guildhall and another real estate plot I use to store stuff). All of my other characters across 2 accounts only had a generic auto save entry, the guildhall entry, and a second real estate plot entry. None of them have guildhall address entries anymore and all of their anchors work.

    Whatever code that generates the plot layouts seems to be the culprit and puts out bad files.
  19. CatsPaws Augur

    OK I think you have hit on something here Veli and this needs to be moved so more folk can see it. My free account anchor worked fine before patch, broke after. My other accounts were broke and are now fixed with patch.
    So since the free accounts cannot place stuff on guild halls or plots, I had set up a normal housing plot for all my free boxes to put their anchors in.Tried anchor and got the red fail message. I had free guy stand in that plot and delete all plot stuff layout in his name. Tried anchor again, failed. Had another char come over and mail the primary anchor to free guy. Free guy placed it again and it worked.

    So in a nutshell, delete layout files in your neighborhood. And I think you can just stand on any plot and delete them all from there: real estate - items - layout on top tab.

    Now something else I noticed is that not all my char have a lot of auto saved plot layouts so not sure what is the criteria of how long these stay in there. One char has them since Dec 2015 and it takes up screen after screen but his anchors work lol and he has address's and plain saved ones so not sure how that affects stuff.

    Anyway thanks for posting and I hope it stays working for everyone.
  20. Malbro Augur

    Yes, this needs to be stickied.

    I deleted all my auto saved layouts, even on my plots.

Share This Page