Fixed Internally Achievements do sometimes not update (here Collection Achievements)

Discussion in 'Resolved' started by Ryhme, Nov 5, 2019.

  1. Ryhme Lorekeeper

    I tried to evolve the TBL tabard and did collection achievements the last months. Wasted a ton of money and time for the ones which did not drop. The collection items are tagged but some Achievements do not update and therefore the Tabard does not allow to get evolved. I did the usual stuff to correct this:

    - rezoning
    - relogging
    - waiting some days (weeks) for the server to update (usual old bug of Achievements)
    - petition (the usual: we cannot do something now, no ETA, /bug it)
    - relaunching Launchpad and do a complete verifiy over the system
    - relaunching Launchpad on a fresh EQ without changed UIs - original pure (besides I only change the new icons with the old ones as the only change of the UI)
    - reclicking all collection items in the achievement tab which is not updating (all say that they are tagged)
    - /bug (did it before the petition)

    non-updating Achievements are:
    - CotF: Bixie Hive Hodgepodge
    - CotF: Dead Relics
    -> therefore CotF: Hearing the Call
    -> therefore all Scavenger parts which include these (I have done all from CotF to even TBL!)

    Normally I am used that the Achievement updates at least the next day Further play with Achievements and their items makes at moment no sense anymore.
    Lessw, Nennius, Duder and 3 others like this.
  2. CatsPaws Just use plain English.

    Running default UI on my characters and 6 of them all have the Bixie Hive Hodgepodge and Dead Relics and in turn Hearing the Call showing as completed.

    The only other old bug in /ach updates that one might need to do is to uncheck the boxes that say "open" "complete" and "locked" at the top of the /ach screen. Sometimes even had to zone then check them again.
  3. Ryhme Lorekeeper

    It is only an assumption but when zoning and rewards are pending then this can bug out because access is sometimes not possible. Going LD because the provider is unreliable while getting the achievement could be another reason. Having the limit of 10+ rewards and getting kicked from the server due to LD (provider issue) could be the same. The code should take that into account but it is a possible critical moment.

    But I don't remember this on my SK. It is always on Gold except the one case in the month when Krono runs out and I have to renew it. All rewards are far under 10 and always taken as soon as possible. But I had some LDs and there were also some server issues the last month where the server kicked everybody. If that happens in the most unconvinient moment then this could be a source for a database mess.

    Normally after relogin or at least verify the installation via Launchpad everything is updated properly. This time - it is not.
  4. Velisaris_MS Augur

    Try having someone link the ach to you, click the link, then click on the "view mine" button. Sometimes that forces the ach to update for me when it doesn't otherwise.
  5. Ryhme Lorekeeper

    This gets more serious. I tested now your method.

    I took out the collection and gave it two other alts.
    One updated properly. The other one is stuck at the same point, same problem. Reopening the Achievements, waiting a longer time, opening/closing - nothing updated. Sending the link from an alt updated it then on the test account.

    The error is simply in the following:

    - "Remnants of the Unlucky" - got updated - but not in "Dead Relics"
    - "Aquired Armaments" - got updated - but not in "Bixie Hodge Podge"

    Which lead into not updating the layer above them.
    The database consistency must need a check/verify run for that.

    Downside to that - the second toon which needs the Tabard updated had now the same problem. I tried your workaround. This time it updated with that trick.

    So there is a problem in Achievements not updated properly/instantly (which is the case since years and had at least some corrections to run better but still has bugs) but if something happens in that time frame then this error gets permanent. Assuming if a LD or a crash might happen in that very moment, then perhaps this combination stays in the wrong configuration and only a complete database consistency check/verify could solve that.

    The code for updating the Achievements needs some serious love.

    Nevertheless my tank wants to have his tabard after months of working on it...
  6. Hitty Augur

    This bug is still active. A very rare occasion but the bug is present.
    10+ active tasks, 1 with the flag, zoning and another bug in the database. Does not get removed with above suggestions or even with paying for active subscription, tagging, linking, etc.

    A correction run over the database with a query/recheck of all achievement tags compared to the summaries of the tags would correct this database error instantly.

    DGB please make an optimization/correction run. The evolving items from TBL are hard enough to play through. If they don't work after months of grinding then that is highly demotivating.
  7. Hitty Augur

    Long update, database consolidation - but no real verification done, obviously...

    Bixie Hive Hodgepodge misses the Acquired Armaments tag, despite all tidbits are tagged as collected.
    Dead Relics misses Remnants of the Unlucky tag, despite all tidbits are tagged as collected.
    Hearing the Call misses the Dead Relics and Bixie Hive Hodgepodge tag and does not update (due to that).

    This bug is still there! Months of collection usefless time wasted so far. If this gets fixed in 3 years, nobody needs the items anymore...doing evolving items with achievements connected is like playing in the lottery.

    What is the use of this bug thread if many issues are simply ignored?
    What is the use of petitions if the "support" can (will not) handle that and we shall "bug report" it (which is meanwhile in many things as useless as doing a petition)?
    What is the use of ingame "bug reports" if things are ignored now for countless patches?

    How shall we as customers handle such bugs else?

    Highly disappointing...
  8. Ryhme Lorekeeper

    Now the next update and the chance to consolidate/verify the database after moving AB and this bug is still present. Cannot use the Tabard. Summary Achievements don't update despite the single achievements are tagged. Please do something. Cannot use the evolvement items for now for ages and wasted months on it!
  9. Enchilada Journeyman

    The achievements are not updating on Explorer here. I assume that is the same problem like in the posts above. I have the case that Halas and the Northwest Antonica Explorer is not tagged while I am zoning back and forth into Halas. On another toon it worked flawlessly.

    I did

    - rebooting EQ
    - repatching EQ
    - linking achievements and clicking
    - loading on another PC


    This achievement system is really messed up. And the Torn Efreeti Boots are now completely useless.
    TBL evolvement items are a really nice idea but putting endless time into it to roll a dice after putting much time into it does not raise motivation...

    This seems to be some kind of uncommon random effect.
  10. Warp New Member


    Token of Droga: Death
    Token of Droga: Tears
    Sign of Droga

    do not update.

    I assume it is the same bug. Doing evolving items too.
    I should add: explorer Achievement is not updating too. Two evolving items from TBL are useless at moment.

    Have a friend who has the same problems. It seems to accumulate since the last patches.
  11. Willowtree Journeyman

    My Torn Efreeti Boots didn't wanted to evolve today. I had to remove the power source because I always had message that I have it equipped with augmentations. Putting it in the inventory didn't helped. Only after requipping them then it said that I don't meet the requirements. Sadly one zone is not activating. I zoned but the achievement is still not present. I patched and quit and logged in again. Nothing. The ideas to link the achivement does not work either.

    This is a terrible bug...
  12. Velisaris_MS Augur

    A couple of things to try...(apologies if you're already tried them)

    - Have someone else link you that achievement and then click the "view mine" button

    - Open up that achievement, then click on another expansion and view a similar achievement in that expansion, click back to the expansion you're having a problem with; that sometimes forces mine to update when it doesn't normally
  13. Willowtree Journeyman

    Yes that has been written in the posts before. After many experiments this worked on the explorer achievement. But I have an issue with the collections not updating too now. This trick is not working on the collection achievements sadly :(
  14. NeverPayForLag Augur

    And too remind that collection achievement sometimes do also not update even with the link trick - here a push... time for a garbage collection, fits to the name: base collection items tagged, summary achievements do not activate, TBL evolving item was a useless timesink so far....
    and obviously cannot click them a second time - so all collections need a serious check run to activate them
  15. NeverPayForLag Augur

    Dark Secrets (Shadow of Fear) do not update and no 15AA are possible to get.
    The sub achievements are granted. The usual link trick does not work on collection achievements.
    Please fix this!
  16. Hamwaja New Member

    I may add here

    Ritual Runes (The Skyfire Mountains) -> Runic Shard of Protection

    no update, no tagging, it says that the item is collected. The idea to link the achievement does not work. Reboot or zoning does not work.

    Gold status, no zoning, no limit of quest rewards, this happened while byuing and activating collection items for many hours the whole night - wasted a ton of money I cannot activate the Tabard - this kind of bug sucks balls...

    The TBL Tabard is stuck and impossible to evolve.
  17. Bughater New Member

    I want to bite in my table...

    I clicked for over an hour the last missing collection items and now two shinies do not update:

    Ritual Runes (the same like the post above)

    Runic Shard of Protection
    Runic Shard of Speed

    I have a fully paid account, latest expansion. This happened while sitting in the guild hall and only clicking countless collection items. Evolvement shoulder item from TBL is now useless, money and time lost. Scavenger achievements are borked.

    Is something wrong with the server since the last patch?
  18. Hailmeabit New Member

    I want to join the fun. The same thing has just happened here. No activation of the Achievement "Ritual Runes", Runic Tablet of Speed is clicked but not checked. This is extremely annoying. The workaround with the link doesn't work either, although this has always worked with the Explorer Achievements. This is highly demotivating bug.

    Scavenger hangs, no AA through it.
    Threadbare Weighted Tabard cannot be evolved.

    The same achievement. This is the night of epic failures. I want to kill something or better somebody...
  19. Tronda Journeyman

    Here my special bump for the latest evolvement item:
    ToV Blooded Militant Mystic Earring of Rallos Zek
    I cannot update it because the collection items are necessary to get the quest and
    Frozen Equipment (The Ry'Gorr Mines): Frozen Steel Orc Earring & Frozen Platinum Orc Earring
    says: I have collected them but they do not tag. It is not fixed by linking the achievement window. The ToV earring is stuck now.

    Bad bug. Maxed out AA long ago. All the time collecting ToV shinies are wasted.
    Is there any bugfix in sight?
  20. MPower New Member

    It seems that since the last patch the Collection Achievements for ToV are sporadically not working anymore. Hunter Achievements were fixable with an external link, this one as described above is not.

    ToV, Frozen Equipment (The Ry'Gorr Mines), Frozen Orc Platinum Ring:

    When clicking on the Shiny the message says:

    "You have already finished collecting Platinum Orc Earring"

    although the entry is still open.

    Gold Status, Magician Level 115, reboot makes no difference, neither does zoning.

    So the "Militant Formulaic Earring of Rallos Zek" is stuck and cannot be developed further.