Unable to complete download

Discussion in 'Game Support' started by boredbean, Sep 17, 2015.

  1. boredbean Level 30

    Hi, really hope someone can help me with this problem. I am stuck at 97.5% download and now I'm receiving this error message: Unable to download SocketError:Connection Timed-out - Destination host failed to respond
  2. boredbean Level 30

  3. LadyLightning Issue Tracker Volunteer

  4. boredbean Level 30

    Thanks for the link, My computer is a fresh install of Windows 10. Shouldn't be ant malware since I haven't installed much, mainly AVG, my drivers and my MMORPG games from steam.
  5. LadyLightning Issue Tracker Volunteer

    Then it might be your security software blocking the download. You could use the Steam version if the stand-alone doesn't work.
  6. boredbean Level 30

    I've lowered all my security settings, still no luck. Disabled my AVG and checked Windows Firewall, which is letting all my games connect and still can't get it to finish. It has stopped and 97% which is weird. It can download, just not finish. All my other MMO's are working fine, just not DCUO.
  7. LadyLightning Issue Tracker Volunteer

    Send a ticket to the Daybreak support. They are slow but they know how to fix the problems with their games the best.

    Since you migth have started downloading during GU 52, it might help to clea the Launchpad cache.
  8. boredbean Level 30

    Thanks. Yes, I tried clearing the cache, with no luck. I have submitted a ticket, still waiting for a response.
  9. lillitmay New Player

    Have you solved the problem? Because I am seuffering from the same issue right now