Steam Fix "Stuck a Black Screen With SOE Logo"

Discussion in 'Game Support' started by Aiden Warren, Feb 15, 2013.

  1. Rashadjc New Player

    Is your PC custom built? If so can you give me a list of parts, if not tell me the name and model of your computer.
  2. APersonOnAComp New Player

    Yeah, it's custom built.

    AMD Phenom II x4 940 Processor (3.00 GHz)
    12.0 GB RAM
    Running a 64-bit OS (Windows 7)
    SLI'd two GeForce GTX 295s (works well enough to display most things at higher settings)
  3. APersonOnAComp New Player

    I did hear that PuppetSoul came up with an workaround on the Steam Forums:

    "So I took the game's executable apart, found the problem (♥♥♥♥ty coding), and found a solution.

    It's failing at the anticheat. The reason it would fail before that if I modded the movies is because it would just skip over them and then fail at the anticheat like normal.

    Disable User Access Control (control panel, user accounts, user access control, slide it all the way to the bottom), and then change your non-unicode support to "English (United States)" to bypass the check it's doing (it's trying to download a file without telling you it's downloading a file, and if it fails it crashes the game).

    Then install (complete reinstall) of the game to c:\progra~2\steam\etc. I haven't tried the steam-installed version, I just downloaded from the site and installed into the steam directory. Yes, you have to put "progra~2" instead of "program files (x86)" in Windows 7, otherwise windows will block it.

    After that, it'll work.

    You can readjust your UAC setting afterward, but the non-unicode can't be changed back or it'll FUBAR the game again."

    The only problem for me is that I tend to work with Japanese software on my computer as well as English things, so I'm usually working in Japanese non-unicode support. Since some of my program files are written with Japanese characters, won't changing the region back and forth mess up those characters and possibly render those programs non-functional even if I switch back to Japanese before using them because they may contain code that looks for those Japanese character file names?
  4. CryHavoc New Player

    None of this works. Still stuck at black screen launchpad nonsense.
  5. Tetsuken New Player

    I too work with japanese stuff on my desktop, so i use the japanese non-unicode support aswell. It COULD be what's causing the problem but i always had that installed and i was able to log in and play normally a few months ago. So unless they messed up so bad that japanese people can't play their game anymore, i don't really know what's going on.
  6. TheDarkKnightIV New Player

    It worked!! Thank you so much :D
  7. Rashadjc New Player

    No problem.
  8. Eternal New Player

    Thanks to all of you guys, but this was by far the easiest fix for my not very computery mind!

    Thanks x1000
  9. AnotherRandomPersonnn New Player

    noooooo! the first fix deleted the patches and made me reinstall it! well, another 4 hours of waiting is ahead. At least I fixed it.
  10. OnceUponATime Dedicated Player

    The steam install of the game is unfortunately rather out of date, so it's normal that it will need to patch (several Gb) once you get your launcher running. Under NO circumstance ever attempt to validate your files via steam as this will reset your install to this out of date version again.
  11. L1verp00lL4d New Player

    Help, when i try to do this i get an error message saying "you cannot save to the root of your program directory, please choose another location" how do i fix this?
  12. Herbalacious New Player

    Thanks for this thread it saved me a headache.

    A returning player, I was kind of excited to try it out again until the crashing started heh. But thanks to this thread it is all good again! Of course I get it working 30 mins before server downtime.

    A brief description of what happened..I don't know if it helps, but the game worked perfectly fine thru the tutorial and first few missions near the beach. As soon as I crossed the bridge towards the city center the game just started crashing each time I logged in. At around level 10. Launcher worked fine, logged in with no issues but couldn't play for longer than 30 seconds. Had to do the file verification within steam which downloaded about 7.4gb and when tried to play I got the black launcher screen. Google brought me here. Did the copy/paste method mentioned in this thread and back in time to see a hotfix about to be deployed and server going down.
  13. TSR-AlexS Customer Service

    Glad this thread helped out your crashing situation! We are glad that you're trying out the game again! Please let us know if you have any more issues.
  14. Hutchyyx New Player

    Wow, this worked!
  15. vampyshadow New Player

    i did every thing but didn't work

  16. Marcadius New Player

    I was just wondering, is there a way to fix this same problem without using Steam? My computer cannot run on steam for other reasons, but I know it will be able to run DCUO ... if only I could just get past the black screen. I had been waiting anxiously for days just to download the game, (It takes days because of my slow WI-FI) and I cannot explain to you how upsetting and disappointing it is to see my computer not run the game properly after all this time. I would really appreciate it if someone were to be able to find a answer to my problem, thanks.
  17. DANtacular New Player

    my problem is when I start the launcher it loads normally and all but when I press play it will change to "playing" but nothing happens the game doesn't really open and I have tried deleting the LaunchPad-user
    and the copy ans pastes thing.