Top Bug - Fixed Solar Amplifier Failing to Burst

Discussion in 'Resolved' started by AV, Sep 23, 2020.

  1. AV Loyal Player

    Since the nerf, the burst at the end of Heat Vision is occasionally failing to go off for no reason whatsoever. Power runs full duration without interrupt and the burst just sometimes doesn't happen. Bug only occurs in actual content, not vs Sparring Targets. Unsure of steps to reproduce but seems to happen just as frequently in alerts and raids.
    • Like x 8
  2. Pale Rage Well-Known Player


    Since the Nerf, I've only used on ST, so haven't used much (haven't been doing bounties either this week much).
    But I have noticed it not exploding a few times, figured it was just because forced target change (add I was focusing on in alert died).
    • Like x 2
  3. AV Loyal Player

    I'm still seeing the normal forced target change loss (which also shouldn't be happening) but also a new, inexplicable loss even on some targets that are still alive and well and nothing at all cancelled the channel or anything. Not super common but happened enough today to bother me.
    • Like x 2
  4. Melusine Midnight Rainbow Phoenix

    I have experienced this as well. One toon at 200 on the Solar, multiple toons at 160.
    • Like x 1
  5. KN1TE Dedicated Player

    Empowered channeling mod also not working/still broken at rank 200.
    • Like x 1
  6. KN1TE Dedicated Player

    Also not burning noobs anymore. I want a refund. That made it the best artifact ever!... LOL! j.k.
  7. Qwantum Abyss Dedicated Player

    I can confirm no burst sometimes. Seems about 50/50 for me and also in content.
    Empowered channeling rank 200 still busted an channels get interrupted alot. Seems about 30/70 for me.
    • Like x 1
  8. qECLIPSEp Well-Known Player

    While I understand you addressed the the damage split, I have noticed on a few of my Characters that Solar Amplifier is not performing as it states in the description. It states, "Enemies near the target will catch fire" at a certain level. My artifacts are at least at 160 which is sufficient enough for it. My target is catching fire but the adds beside it are not unless they walk into the beam itself. Could you please look into this discrepancy?
    • Like x 1