Up-Votes Needed Single Target pets not attacking from time to time

Discussion in 'Arkham Asylum (Bug Reports)' started by Pinky, Nov 10, 2021.

  1. Pinky Well-Known Player

    Green Crystal Turret (Tier 3) from SM Season 1 is not working on first use. ie. when character first logs into the game. It only works on 2nd usage onwards.

    Steps to reproduce the bug:

    1) Log into the game

    2) Go to training dummy, engage in combat ie. activate a superpower or weapon attack

    3) Use Green Crystal Turret.

    4) Observe that the Green Crystal Turret appears but does not attack any targets even though my character is in combat mode.

    5) Wait for the Green Crystal Turret to finish its cooldown.

    6) Go to training dummy, engage in combat ie. activate a superpower or weapon attack

    7) Observe that the Green Crystal Turret works normally now and attacks my target

    8) Log off character

    9) Log in using the same character

    10) Engage in combat with a training dummy

    11) Green Crystal Turret works normally and attacks target

    13) Log off character and exit the game completely.

    14) Start up the game client again and log into my character. Green Crystal Turret bug happens again as described in steps 2, 3, and 4.
    • Like x 5
  2. xxHELLSTROKExx Loyal Player

    I think it may be all st turrets. My source one from sm rarely works and my gen turret t3 one hasn't worked once that I've noticed.
    • Like x 1
  3. Rejchadar Inquisitor

    Are you sure pets don't attack and this is not a visual bug? I mentioned a visual bug a few months ago during the final stage of testing the pets tier system and, alas, it migrated from the test server to a live one, and repeating the steps that you described it is not difficult to reproduce ... the beam is not visible, but the damage is done ... I tried several times those steps that you described and I was able to reproduce only a visual bug ... in the log the damage is displayed regardless of the presence or absence of visual effects ...
    • Like x 2
  4. Hunted2468 Well-Known Player

    Are you going by what you see the Turret doing or by what the Parser Tab is saying? I couldn't reproduce this at all with the T3 Brainiac Turret. Logged on / off 6x. If you're going by the visuals of the turret i'd be inclined to agree with Rejchadar and it could simply be a Visual Bug. Still a bug, but a much lower priority one. If however you're going by the Parser and theres no "turret damaged for X amount" showing, yet its not happening with mine, it could help narrow the Bug down to Older Turrets.

    I think this would all need to be clarified 1st.
  5. Illumin411 Loyal Player

    It's only with the single target turrets (green crystal, source lightning shard, ensorcelled gem turret, anti-matter turret). I've noticed this bug too with both my green crystal turret on my main and the source lightning shard turret on my alt though had yet to properly test to reproduce it. AOE turrets like the Brainiac Turret, Snake Turret, Shadow Snake Turret and Freeze Turret don't seem to have this or any similar bug.
  6. Hunted2468 Well-Known Player

    Ok so that leaves the main important question though, is this being judged by looking at the Turrets animation or by referring back to the Parser Tab? If anyone has recording capability then a video would help the Devs more than just descriptions if it is a Bug evident on the Parser Tab
  7. xxHELLSTROKExx Loyal Player

    I'll try to test tonight on sparring target. Tho I'm assuming that they'll just work as they should there. It's in real world stuff that I have issues. And since I'm a pet build, orange numbers are always flying. So I'll change my combat log around and give it a whirl and report back.
  8. Rejchadar Inquisitor

    Before the first answer, from the beginning I checked all the mentioned + Anti-mater turret on sparring target, then I thought about it and checked it in open wordl on small open world bosses (for clarity, I used the original bosses from the original Gotham, one weapon attack is weakly noticeable and the turret killed the boss every time during the action ) ... I did a couple of tests (alas, lately I have very little time for DCUO :( ) for each turret ... and here and there I was able to reproduce a visual bug, but the damage was always regardless of the presence of the beam or its absence. .. if you have time ....and ... laziness ;) ... allows, check for damage in some duo, alert or raid ...;)
    • Like x 1
  9. BumblingB 15000 Post Club

    So... This isn't just with the trinket pets. I have observed Quislet, RSK, and Suppressor Turret do the same behavior. They didn't do this before and you just needed to be in combat. I think this might have appeared after Allies came out and how they attack enemies based on your threat level.

    The reproduction is to be in combat before summoning pets and not attack.
    Get in combat.
    Summon pet.
    Watch pet sit there.
    Attack target (power or weapon)
    Watch pets attack.

    Edit: to clarify, it probably is more related to test dummies than enemies in real situations.
  10. Pinky Well-Known Player

    Hi Rejchadar, you are right. I checked again using the steps I mentioned in my OP and it is actually a visual bug as you described. The combat parser records the damage done by the Green Crystal Turret, but there is no green beam from the turret to the target dummy to visually indicate that the Green Crystal Turret is actually doing its damage. It is a visual bug. The damage ticks can be seen above the target dummy which is taking damage, but there is no green beam from the turret to show that it is actually performing its attack.
  11. Pinky Well-Known Player

    I rechecked. It is a visual bug with the Single Target pet not showing its attack. The attack damage is recorded in the combat parser, and the damage ticks can be seen above the target being attacked by the Single Target pet. It's just the visual attack animation by the Single Target pet is not shown, as Rejchadar has mentioned above.
    • Like x 1
  12. Hunted2468 Well-Known Player

    I suspected so. Still a bug and still needs addressing ofc, otherwise we might end up with multiple players thinking the dmg is bugged too, but at least now we know its a smaller bug that doesn't affect gameplay at all while it waits to be fixed. Thanks for testing.