In Progress New LoD School of Hard Knocks feats busted

Discussion in 'Arkham Asylum (Bug Reports)' started by Psycho Tech, Mar 9, 2022.

  1. Aetrius Well-Known Player

    This doesn't seem to be a PC/PS issue. We were running the duo last night, I'm PC and got the elite version of the feat on one character, but not the regular despite running the same set-up through both instances while my PS partner got it on elite, but not on reg. I was able to switch characters and get the feat for the regular version.
  2. AZPrime Active Player

    Did some testing for this one last night. Taking any sort of buff consumable before entering the instance (i.e. an omega, buff soder, seasonal treat, etc.) renders the feat invalid. As far as I can tell, this was never the case before for this type of feat.

    In addition to that, there's also a bug in that even if you had consumed one of the above and waited for them to wear off before entering the instance (including checking that there was nothing listed under the current effects list), the game doesn't recognize the consumable as gone until I relogged and ran the instance yet again while satisfying the feat conditions.
    • Like x 1
  3. Belthazur Dedicated Player

    I Literally Did Just this 4x in a Row TODAY and My Partner Gets the Feat I Do NOT
    Im Done with this STUPID Feat.
    I Ran this NO Ultility Belt, Relaced my Legs with Unmodded ones had ZERO Heals in or Out and Still No Feat.
    Also No Super Nor did i use ANY Pets Or Allies
  4. Mepps Sr. Community Manager

    We are working on it.
    • Like x 4
  5. Belthazur Dedicated Player

    Thank You Kindly for your Reply
  6. whitefatee New Player

    I'm on switch and running into same problem my partner was able to get them just fine had no soda removed all trinkets and pets
    • Like x 1
  7. Hotgirlzz Well-Known Player

    I thought my feat was bugged to. But came to find out it was the nth metal detector that stopped it from popping. Never thought as them being a consumable.
  8. Psycho Tech Dedicated Player

    Just got it on 2 alts doing the exact same as my main.. bs
  9. Stranger Well-Known Player

    I didnt get the feat because i crashed when entering the raid and being reinvited. Everyone else got it. Please change this...
  10. Belthazur Dedicated Player

    Just got the Feat in Reg buy having a Leaguemate do All the Work. I just watched.
    We Then Went to Elite and I Dps'd He got Feat I Did not. Im thinking its a Quantum Thing
  11. ODeeSTeeDown New Player

    Tried last night on xbox w/ LG mates. In both cases, the party leader of the duo got credit. Could be similar to a problem from awhile ago w/ omnibus only giving progress to party leaders for alerts and raids? Will try again later to test this theory
  12. TheLQ-DCUO Loyal Player

    Had the same issue just now in SDe standard. Some of the group got feat and I didn't, on EU. I was on PS5 and others on PC.

    I didn't use any SC or consumable for the entire run. The only things I used were Central City Trinket (Medic's Compartment trinket), accomplice, supply drop and orbital strike from my utility belt.
  13. Charon Lead Content Designer

    Found a bunch of possible reasons and should be addressing most, hopefully all of them, in the next hotfix.
    • Like x 2
  14. Psycho Tech Dedicated Player

    Thank u as always Charon, as fast as these were addressed, can u please pass on my Phoenix cannon thread? Thats been broke far too long w no reply, & plenty of thumbs up
  15. Sir Freeze Active Player

    I got the issue in the duo ones did it in reg and no feat popped ( no supercharge no soda etc
    • Like x 1