Launchpad error 4-503

Discussion in 'Game Support' started by ShivamJ, Jan 14, 2016.

  1. mtanasas Well-Known Player

  2. Lumpy New Player

    So I tried deleting the "LaunchPad.Cache" as some of you suggested and now Launchpad will not launch at all.
  3. LadyLightning Issue Tracker Volunteer

  4. Skythief75 New Player

    Took me a while but i finally remembered what you have to do. It's your internet options if you're running dc universe on your pc. Go into control panel and go to internet options. Choose Advanced tab. The choose reset internet explorer settings. That's it!!
  5. Dcuo2017 New Player

    Same Thing just happed to me, I tried everyone else's method and it worked until I logged of. Now Its doing the same thing
  6. recoil Committed Player

    if you have multiple or just one firewall you have to allow permission for each antivirus and security app or it won't work. also you may have to clean install if a virus or corrupted game files. i had the same errors until i set the launcher as a permitted app in ALL antivirus firewalls.
  7. LEXLIGHTER Level 30

    You can do all they said but nothing is going to help it out. It is some internal error...they need fix this because it happens to thousads of people i think.Someday ,someone may fix it....who knows :(