Game Update 24 Error

Discussion in 'PC Technical Support' started by Shadowsabre, Mar 12, 2013.

  1. Shadowsabre New Member

    I'm receiving the following error when trying to download the new game update:

    Unable to download SocketError:Host Not Found (11001) -

    I have tried validating the game files through the Launchpad as well as disabling my firewall, and to no avail. Please help
    It's also worth noting that the previous game update (23) also gave me A LOT of trouble with similar errors that took a long time to get through. This is incredibly irritating, so if possible I would like some advice on how to apply a permanent fix...
  2. TSR-AlexS Customer Service

    Try running the game as administrator and let us know if that made a difference. If it doesn't, then please submit a support ticket with both your Dxdiag and Msinfo so we can further assist you.
  3. Saigon Psycho New Member

    I am receiving the same message. I have updated my firewall settings. I have tried validating game settings, and I have tried running as admin.
  4. TSR-AlexS Customer Service

    I'd recommend submitting a support ticket to our tech team so we can further assist you.
  5. Saigon Psycho New Member

    I sent in a support ticket 3 days ago and no on has gotten back to me.

Share This Page