Up-Votes Needed Can't switch armories during combat

Discussion in 'Arkham Asylum (Bug Reports)' started by Phia, Aug 24, 2022.

  1. Phia New Player

    I have tried everything I can think of to fix this problem and it still doesn't work. I've tried reinstalling the game, I tried taking off all of my gear and placing it back on my character as equipped. I reset all of my skill points. I replaced all 3 of my armories and reimprinted my builds. Anyone else have any suggestions? I need help!
    • Like x 1
  2. Salina Horsemead New Player

    Has this even been addressed yet? This is very problematic for my league mate as they are not able to utilize armories the way that they’re intended. It makes running content a pain when they cannot use the basic functions as the support staff told her to post here as they didn’t want to deal with this issue.
  3. MrMigraine Devoted Player

    Not sure if this is helpful in your particular situation(s), but on PS, I've never been able to swap armories during combat if I have something targeted. I have to untarget (and sometimes fly up and face away so that I'm not targeting an add or something) and THEN change.

    I hope that helps!
    • Like x 1
  4. Big Will Level 30

    Make sure you don't have auto lock target on
  5. Kestral Committed Player

    That shouldn't matter. I've never run without Auto target lock on and the armories still work in battle for me. PC Player. Unless this is PS only issue?