Up-Votes Needed Can't place Armories in Wayne Manor

Discussion in 'Arkham Asylum (Bug Reports)' started by thedemonocus, Sep 17, 2021.

  1. thedemonocus Loyal Player

    I tried to move 1 of my armories, i picked it up and removed it from my old base went to my manor and no matter where i tried to put it the armory would not show up on my list so i had to put it back in my old base so is there some issue with armories and the new manor i don't know about?
    • Like x 1
  2. Mepps Sr. Community Manager

    Were you placing your armory in free placement or in one of the nodes?
  3. thedemonocus Loyal Player

    nodes
  4. MAGNETOxxFirstClass 15000 Post Club


    It does not work in the nodes... but works fine with free PLacement mode.

    Here is video evidence... towards the end. ;)
  5. thedemonocus Loyal Player

    Just tried free placement mode and was able to place the armory but when i activated it ,it shows as empty so i put it back in my old base because if i can't see what build is in the armory its useless to me
    • Like x 1
  6. DeitySupreme Loyal Player

    That bug isn’t exclusive to the manor base. Some of my armories appear as empty even when they are there is a set up active on it. Luckily I remember which is which
  7. TheLorax 10000 Post Club

    Some of the wall nodes are also bugged, some wall items will not appear in the list of available base items.
  8. Future Nightwing New Player

    Upon moving my base and selecting the Wayne manor style certain base items as well as (and more importantly) one of my armories completely disappeared from my base items list and cannot be found. Every time I attempt to change to that armory build I get the “there is no armory associated with this build” message. I only have one base so there’s no option for me to “switch bases” to see if those lost base items are somewhere else.
  9. Mepps Sr. Community Manager

    What other bases have you seen this in?
  10. RunfromDanger Man Dedicated Player

    It happened for about a day in my space base. There was one single armory (out of 16 in that space base) in which the mannequin wasn’t visible. It was the same idea with that one armory as it has been with manor. The mannequin absent but it is imprinted and quick key works.
    Just that one armory, titled Nada, was empty at like 10am and like 4pm the next day (when I got off work) Nada was back in his armory.
  11. DeitySupreme Loyal Player

    I can look through different bases and see which bases are affected if it helps. I’m pretty sure I have all the bases so it shouldn’t be much trouble
  12. TheLorax 10000 Post Club

    I've seen this in the Atlantis base. One time it was just one mannequin, a second time it was all the mannequins. Always fixes the next day.
  13. thedemonocus Loyal Player

    I have seen it in other bases too but its not the same because with the other bases it will fix itself (usually the next time you log in) but with the manor your armories will never display your builds at all.
  14. Future Nightwing New Player

    Update: I ended up purchasing a new armory to replace the one that was lost in the glitch/bug because that build in the armory is crucial to my play style . Hopefully when this issue is resolved I will at least get reimbursed for having to buy a new armory and or compensated for having to go through all of this after purchasing the new manor lair. It’s never fun when spending money in game creates problems instead of rewards.
  15. TheLorax 10000 Post Club

    If you were attempting to place that armory in one of the pre-set circles there is a bug that hides base items in your list. You have to place the armory in free mode in order to see it.
  16. TheLorax 10000 Post Club

    Just noticed all my mannequins have disappeared in my Gothic lair. :)
  17. Future Nightwing New Player

    I’ve tried both desperately lol, that armory is gone into the afterlife somewhere
  18. Captain1Dynamo Committed Player

    Raised a toon from Level 1 to 25. Received my 1st armory. It cannot be placed in the Manor Lair. I can place it in any other Lair type, but not the Manor (I moved lair several times to test this). When I go to Decoration Mode in the Lair, the Armory does not even appear on the list. Looked at blue & pink circles. This toon only has 1 Lair, so the Armory is not in a different Lair. Toon is on PS, has Celestial power, is a villain. Lair is Manor type, attempting to place in Gotham.
  19. TheLorax 10000 Post Club

    This has already been reported and it affects most base items. Your only option is to free place your armories until they fix it.
  20. Captain1Dynamo Committed Player

    Being a new toon I didn't have free placement. But after placing 4 other items the armory appeared on the list & I was able to place it on a blue circle.