Buying DB cash in game by steam don't work

Discussion in 'Old Arkham (Bug Archive)' started by exxtazy666, Nov 19, 2018.

  1. exxtazy666 New Player

    As in the title when i go marketplace and try to buy db cash i have the game by steam it say chosse option of payment i press steam and site is loading infinite and i cant choose anything because there is infinite loading can u fix that bug so players using steam can add they db cash from steam?
  2. Mepps Sr. Community Manager

    Thank you for the report.

    Can you tell me about what time this happened, what region you are playing from, and the character name?

    Does it continue to fail?
  3. exxtazy666 New Player

  4. exxtazy666 New Player

    Eupc poland it continues to fail i tried add funds last week but it not working so i tried today and again the same u can look on the screenshot i gave in link and its all the time the same only loading and nothing can u fix the problem?
  5. Ace G New Player

    This has been a problem since months now, I can't remember if it happened after revamp or something like that. Several of my friends and me included, have this problem. We enter in the marketplace, we try to add cash via steam and then: infinite loading. It happens every single time to all of us. We play US server.
    • Like x 1
  6. LadyLightning Issue Tracker Volunteer

    You should double check if the Steam overlay is enabled for DCUO. Clicking that button is supposed to open the overlay.
  7. Dstdnt New Player

    I can also confirm that I have experienced the exact same issue on the US Server with the infinite loading issue when selecting the Steam option for over a year now. I also have Steam overlay enabled and contacted Daybreak Help, which have been able to assist me before concerning other issues, but since they were unable to replicate it on their side there was no way to find a fix, but hope there can be one found now. I have been able to purchase DB through the site itself and the Steam option does work with PlanetSide 2, but would really hope it'd be possible for the Steam DB purchase options to be fixed through DCUO since I play it much more often.
    • Like x 1
  8. exxtazy666 New Player

    So can we get some information about the fix and somone will take care of the problem?
  9. IcyStone Active Player

    The problem is the steam in-game overlay. I had same problem. Even tho steam overlay is enable on steam its not working. I resolved by stopping running as admin and run as normal. If you are running as normal, try as admin.
  10. Mepps Sr. Community Manager

    We are investigating. Thank you for all of the information so far.
  11. Mepps Sr. Community Manager

    If you are seeing this, can you go here: SteamLibrary\steamapps\common\DC Universe Online\UNREAL3\BINARIES\WIN32

    (or wherever you have steam DCUO installed), right click DCGAME.EXE, select properties, and then look under the compatibility tab? Are you running as administrator or with any other settings checked here?

    Side question, which version of windows are you using?
  12. Schimaera Devoted Player

    I had the same problem. The "return to your transaction" button didn't work. Yet, upon closing the window just with [x] I was returned to the authorization process and could authorize the sum I wanted. Then it returned me to the game and granted me the DBC I wanted. It's kinda weird tho.
  13. Ace G New Player

    Here goes the tests results on WINDOWS 10 (steam overlay always ON):
    I runned the game as administrator as Mepps sugested, no results.
    Administrator on + win 7 compatibility, no results.
    Administrator off + win 7 compatibility, no results.
    Administrator off + no compatibility selected (as usual), no results
    The screen on "Select your day break cash bundle" option is still loading forever.
  14. Dstdnt New Player

    I was suggested that by Daybreak Help and still does not make a difference. Exactly same as Ace G, Win 10, normally nothing checked, and tried it with the addition of trying without Compatibility as normal, with Win 8 & 7 Compatibility, tried with Admin on & off for all options, same issue persists.
  15. Mepps Sr. Community Manager

    Thank you for trying, and for the info. Has anyone tried a full delete and reinstall?
  16. IcyStone Active Player

    W
    I just remembered how exactly i solved the same problem.
    When you turn on you pc does steam show the intro promotions or it always updates and doesn't? If not restart steam but not pc. Try again
    I had same problem. Steam overlay wont work unless the intro promotions display, its some kind of bug or something.
  17. Dstdnt New Player

    I had attempted a delete & reinstall twice, & restarted Steam with & without Steam beta to see if that interfered in anyway, the issue still persists. I believe LadyLightning mentioned prior that they did an update to Steam last year so DCUO purchases from Steam no longer require having to manually enter the CD Key on the DCUO Site, perhaps when that fix came up it affected some players? Not certain.
  18. Mo Kenway New Player

    Yes Mepps, i've done that 2-3 times already on my steam account but it's still the same.
    Deleting the game and redownloading it is nothing but a waste of time and it sadly doesn't fix the problem.
    I'm also another person who's having this problem and had it for a very long time now and i really wish you guys could fix it so i can enjoy the game & spend money on it once again.
  19. Mo Kenway New Player

    Just tried doing what you suggested and nope, still the same problem. :(
  20. LadyLightning Issue Tracker Volunteer

    I excluded all common local causes with Mo Kenway - even a different PC shows teh same isse with the account. At this point this might be account, country or currency-specific.

Share This Page