Armory and Character Switch not working

Discussion in 'Oracle’s Database (Guides)' started by AncientSpirit, May 25, 2021.

  1. AncientSpirit Level 30

    When I log in with my PC (North American) character RubyRed Witch, I am in DPS mode. However, when I tried to change into my Healer role, it won't change. It tells me that that build doesn't have the required 186 points. (It does.) Then when I tried to recreate the character and resave in that armory, it won't let me do that, either -- and says INVALID under the armory. I have tried eliminating the armory and then replacing it, but that doesn't work either. Still says INVALID under the Armory.


  2. Reinheld Devoted Player

    Did you recently switch powers or movement? That can also make an armory invald, but if you recreated it from scratch that should eliminate that issue. Not sure what you mean by 'recreate the character' as if you deleted the character you'd have lost the armory entirely...I'm thinking you meant a full reset and rebuild of the armory? Assuming the info you are giving is correct (rebuilt and now having the minimum SP assigned), I'd say you have a ticket to submit.

    With no other info to consider, if I have an 'invalid' armory, I can normally step up to it in my baes then click 'apply all' and then I am in that armory stance. Once applied, you can add the missing SP, and re-imprint to make it active again for on the fly switching. If you have not done that stuff, try that first...otherwise I'd say drop in a ticket.
    • Like x 1
  3. valiant Villian Well-Known Player

    Make sure the character does not have any 'unspent' skill points. I had the same problem once but once I spent the skill points I had accumulated, it went away. I think this happens if any character has more than 10 unspent skill points.
  4. DeitySupreme Loyal Player

    If you switch powers the armory will now need to be respecced. The same happens if you switch movement mode (except with flying and skimming). If you didn’t change anything than it is because you gained a skill point and the armories that are invalid now have 10+ skill points not placed in anything. To fix this go to each armory and activate them manually through the armory. Put the 10 skill points into something and save them over the previous specs.