Arkham Asylum Alert: Unable to go on after Nightmare Asylum fight

Discussion in 'Old Arkham (Bug Archive)' started by T20thoughts, Apr 27, 2013.

  1. T20thoughts New Player

    A group I was in had just finished the boss fight against Alyce Sinner turned into a nightmare as her fear level reached 100. As she got knocked out, we moved on to Scarecrow, who pretty much just stood there as we burned him down. Following this, we got stuck in the boss room while crows kept coming down and doing slight damage.

    We had no way of getting out of that other than letting the crows VERY slowly kill us, or just disconnecting from the game. One of us disconnected, and succeeded in kicking us out of the instance as well once invited back in.

    Once we all got out of the room, one way or another, the boss fight simply restarted. We'd had enough by then (since it takes ages to wait for the counter to get there, and that was the only reason we were doing the alert at that point), so we didn't try to see if it would work properly the next time.

    Two things of note: During all of this, the bug where sound effects occasionally cut out had kicked in for me for a couple of alerts (having been triggered by a large amount of adds onscreen in an Oolong speedfeat earlier), and during the fight there was also an almost-dead frightened inmate add on the other side of the door, trying to get in. Killing said add didn't help things.

    It feels like what happened was that Scarecrow got killed before he could disappear and reappear, and that confused the game.
    • Like x 2
  2. undrline Issue Tracker Volunteer

    Had a similar issue last night. The part where Scarecrow disappears to lull you into a false sense of security, he never comes back. The terror level keeps rising. If you wait long enough, with the terror crows randomly descending on teammates, you can defeat the Nightmare, but still no Scarecrow, you're still in combat, and the door doesn't open. Glad we could disband.

    If you search the Arkham Asylum forum for Scarecrow, it seems this is a common occurrence.
  3. Dr Petros Well-Known Player

    Yeah, I was trying to carry my roommate (a T1 tank) through this and myself being a tank figured why not give it a go just the two of us. It took us a long time but we finally got to the scarecrow fight and when we did so experienced exactly the same glitch. We killed scarecrow after the fear counter had reached 100 (a tank and a half is hardly the ideal group for doing fast damage) and he stopped moving around, put his hands on his hips and gloated. We went for scarecrow first hoping that it would be a quicker end to the boss fight but when that proved incorrect we went on to Sinner's nightmare and whittled it down as well. FINALLY we finished her off only to realize that the game had glitched, we were stuck in the room and the terror crows kept swooping down doing very minimal damage to us but not being targetable or pullable themselves. This stinks...

    So here's the fun part, I had no way of leaving the instance... We had done a walk-in since one of us was T1 so there was no option to disband the instance. I tried warping to rally, which doesn't work in combat. I tried switching characters which also doesn't work in combat. Finally I ended up exiting the game completely and restarting it which worked but I think it's kind of dumb that all that time and effort went down the tubes because of a glitch.