“Delivered Fast, They’re Free” Feat (Fellowship Elite) bugged?!

Discussion in 'Old Arkham (Bug Archive)' started by FALLEN-ONE, May 8, 2019.

  1. FALLEN-ONE Active Player

    Ok so to begin with, the description is very confusing ... Last Atlantis DLC there were two feats: Risen Runner and Sea Beast (Mode) both elite. Both of those feats are NOT 1 single attempt but are worded exactly the same as “Delivered Fast, They’re Free.”
    We have gotten all the ingredients before all the 11 of the Obelisks spawned but NO FEAT! We had 8 and 9 obelisks delivered and have done it multiple times on first try! No feat ever appeared even though we have completed it on first attempts on more thwn 7 occasions and then killed the boss, times after times we kept disbanding it and rerunning the instance, thinking we miscounted but apparently that was never the case. The feat just doesn’t pop so idk what the hell is going on... Books were delivered in less than 3 minutes ON FIRST TRY! We had 9 obelisks by the time we were done and then we killed Fate and all this was done without wiping on more than 3 occasions. Please check the feat description and whether or not it’s bugged.
  2. FALLEN-ONE Active Player

    A feedback from a dev would be nice
  3. FALLEN-ONE Active Player

    Another bump
  4. FALLEN-ONE Active Player

  5. JackFrost Developer

    Sorry I didn't see this note before. I'll take a look at it and make sure it's working correctly, or submit a fix if it isn't.
    • Like x 1
  6. Luke© Well-Known Player

    I can tell you from my experiences:
    you wont get the feat, when you've door bug. It never worked for me, neither my group, if door was open through the fight (and less than 11 obeliks). Worked always fine when door wasnt bugged.
    Devs didnt care for door bug too yet, but i found out how to trigger it, more or less. While you have to run through the maze of books, to get to klarion/doctor fate/felix faust, you open the door, and then run right into him and press any attack (before the scene starts). This way the door has been always bugged for me. Hope devs gonna fix this some day...
  7. JackFrost Developer

    Thanks for the additional information!
  8. FALLEN-ONE Active Player

    We don’t need to glitch the door to follow the description on the feat. I’ve had the door glitched on us two or three times total but I have no idea how it works tbh and never ran the raid going for this particular feat with the door open the entire time. We have no issues completing the boss with <11 obelisks at the end and have done so multiple times on first try without wiping and dozen of times with wipes. No feat ever popped.

    Thank you very much! I’d imagine you’re very busy already but an update on this would be really apreciated.
  9. Jay Smeezy Dedicated Player

    Dang...savage! U just hurt a lot of folks’ feelings...lmao! Honestly there is no need to glitch that door. I always thought it was just some random bug! Never knew there was a method! o_O o_O o_O o_O
    • Like x 1
  10. FALLEN-ONE Active Player

    Lots of people are popping the feat now and have it but those who actually complete it lmao
  11. JackFrost Developer

    The door issue should be fixed as of a patch earlier this week. That door issue could have caused issues with the Feat not completing, so please respond if you're still having issues completing this feat. Thanks!
  12. GoDeacs Well-Known Player

    Cannot login onto account due to Auth error 46. Been like that for a while. Ran this again multiple times and have completed the task-still no feat. I’m not sure what the issue is but a lot of people have gotten the feat out of the blue. Almost feels like it broke on my end... Could you please take a look at this feat again and hopefully resolve the issue? Thanks